summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Reinert2018-01-29 16:46:08 +0100
committerJoakim Reinert2018-01-29 16:46:08 +0100
commit95588f144ea34e9ba5aef4cfcf40c2d7a451a7a9 (patch)
treee1de51383d4c185b2d1d56de7b2e72542d876b9e
downloadaur-95588f144ea34e9ba5aef4cfcf40c2d7a451a7a9.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD42
-rw-r--r--audition-git.install3
-rw-r--r--audition.service10
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe38f33f1f07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Mon Jan 29 15:46:01 UTC 2018
+pkgbase = audition-git
+ pkgdesc = Simple now-playing server
+ pkgver = r1.7f43782
+ pkgrel = 1
+ url = https://github.com/jreinert/audition
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = crystal
+ makedepends = shards
+ depends = gc
+ depends = libevent
+ depends = pcre
+ provides = audition
+ conflicts = audition-bin
+ source = audition::git+https://github.com/jreinert/audition
+ source = audition-git.install
+ source = audition.service
+ sha512sums = SKIP
+ sha512sums = 879788a9cf0c6bd609f22e27c83c8889e0649a0f5af44609495936cb31a4ed85f8e7bf0981794a9098a5fcd00c1bb150a6e06ea157cee99fcf28feb50260b9af
+ sha512sums = f8e89fad14a3ba3cf030fa64bbd12edb2bbab8b82a897beda53a545bf6fdb4d1c34e2d2ae7cd9204b3b342a84038c7151ec49ed6b5640da0d266146ed63eb4ff
+
+pkgname = audition-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53c2e4e91de9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Joakim Reinert <mail+aur@jreinert.com>
+_name=audition
+pkgname=${_name}-git
+pkgver=r1.7f43782
+pkgrel=1
+pkgdesc="Simple now-playing server"
+arch=(i686 x86_64)
+url='https://github.com/jreinert/audition'
+license=(MIT)
+depends=('gc' 'libevent' 'pcre')
+makedepends=('git' 'crystal' 'shards')
+conflicts=('audition-bin')
+provides=('audition')
+source=(
+ "${_name}::git+https://github.com/jreinert/audition"
+ audition-git.install
+ audition.service
+)
+
+sha512sums=(
+ SKIP
+ 879788a9cf0c6bd609f22e27c83c8889e0649a0f5af44609495936cb31a4ed85f8e7bf0981794a9098a5fcd00c1bb150a6e06ea157cee99fcf28feb50260b9af
+ f8e89fad14a3ba3cf030fa64bbd12edb2bbab8b82a897beda53a545bf6fdb4d1c34e2d2ae7cd9204b3b342a84038c7151ec49ed6b5640da0d266146ed63eb4ff
+)
+
+pkgver() {
+ cd "$_name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_name"
+ shards
+ shards build --release
+}
+
+package() {
+ cd "$_name"
+ install -Dm755 bin/audition "$pkgdir/usr/bin/audition"
+ install -Dm644 audition.service "$pkgdir/usr/lib/systemd/system/audition.service"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/audition-git.install b/audition-git.install
new file mode 100644
index 000000000000..5118f2fcc485
--- /dev/null
+++ b/audition-git.install
@@ -0,0 +1,3 @@
+post_install() {
+ useradd -M -s /bin/false audition
+}
diff --git a/audition.service b/audition.service
new file mode 100644
index 000000000000..483505c5c05a
--- /dev/null
+++ b/audition.service
@@ -0,0 +1,10 @@
+[Unit]
+Description = simple now-playing server
+After = network.target
+
+[Service]
+ExecStart = /usr/bin/audition
+User = audition
+
+[Install]
+WantedBy = multiuser.target