summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-03-07 13:50:05 +0100
committerPhilipp A2019-03-07 13:50:05 +0100
commit4ecc55c796e1e6cebb58c627a254bfe414d31038 (patch)
treeca8fb35b6212ed3a919d655fdcd9ea46d90e4697
parent4e05eebf6d4923a169d1982ddb52ce3c206e320b (diff)
downloadaur-4ecc55c796e1e6cebb58c627a254bfe414d31038.tar.gz
v2.0.0
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e88f3d0fec2f..931ebcc42485 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,8 +5,7 @@ pkgbase = auditwheel
url = https://github.com/pypa/auditwheel
arch = any
license = MIT
- makedepends = python-pip
- depends = python
+ depends = python-wheel
depends = python-pyelftools
noextract = auditwheel-1.9.0-py3-none-any.whl
source = https://files.pythonhosted.org/packages/py3/a/auditwheel/auditwheel-1.9.0-py3-none-any.whl
diff --git a/PKGBUILD b/PKGBUILD
index 8afc433dc31e..edfb0af3054c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,15 @@ pkgdesc='Cross-distribution Linux wheels'
arch=(any)
url="https://github.com/pypa/auditwheel"
license=(MIT)
-depends=(python python-pyelftools)
-makedepends=('python-pip')
-_wheel="$pkgname-$pkgver-py3-none-any.whl"
-source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
-noextract=("$_wheel")
+depends=(python-wheel python-pyelftools)
+_pyarch=py3
+_wheel="$pkgname-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${pkgname::1}/$pkgname/$_wheel")
sha256sums=('daa496bb307012502dd70ba6116b14e28849a30e93b290fb403e83b4926c8918')
+noextract=("$_wheel")
package() {
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}