summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-07-24 13:03:38 +0200
committerPhilipp A2017-07-24 13:03:38 +0200
commit65bc19d4dc48ef46c9f0e41ce5eaebcdcae4221f (patch)
treeda1ac529e84a06d8106fd82df7113ab6cfc2de75
downloadaur-65bc19d4dc48ef46c9f0e41ce5eaebcdcae4221f.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0163377a3a42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = auditwheel
+ pkgdesc = Cross-distribution Linux wheels
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://github.com/pypa/auditwheel
+ arch = any
+ license = MIT
+ makedepends = python-pip
+ depends = python
+ depends = python-elftools
+ noextract = auditwheel-1.7.0-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/14/76/290bbad9533b5749d37863008b811bb625ff3c2e76fcd8e7b9f492bf39dc/auditwheel-1.7.0-py3-none-any.whl
+ sha256sums = 92b4e9bd2624c5ba06149cb186702d1dffed08bfc19d467a19291007722d0ebb
+
+pkgname = auditwheel
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4d7ad300862e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.whl
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be3ea5af60db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+
+pkgname=auditwheel
+pkgver=1.7.0
+pkgrel=1
+pkgdesc='Cross-distribution Linux wheels'
+arch=(any)
+url="https://github.com/pypa/auditwheel"
+license=(MIT)
+depends=(python python-elftools)
+makedepends=('python-pip')
+_wheel="$pkgname-$pkgver-py3-none-any.whl"
+#source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
+source=("https://files.pythonhosted.org/packages/14/76/290bbad9533b5749d37863008b811bb625ff3c2e76fcd8e7b9f492bf39dc/$_wheel")
+noextract=("$_wheel")
+sha256sums=('92b4e9bd2624c5ba06149cb186702d1dffed08bfc19d467a19291007722d0ebb')
+
+package() {
+ pip install --compile --no-deps --root="$pkgdir" "$_wheel"
+}