summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2016-06-26 03:42:09 -0400
committerbrent s2016-06-26 03:42:09 -0400
commit632b924572937b43f32ba6f17975e8728a3a9c36 (patch)
tree15d70630fec3b100624df1ef5450f58ab3212b74
parent97986bbfe956e31958f856c400cc21b1fb96c854 (diff)
downloadaur-632b924572937b43f32ba6f17975e8728a3a9c36.tar.gz
successful build. yay!
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 30 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 155c2d13c81a..d0d813da572c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
# Generated by mksrcinfo v8
-# Sun Jun 26 07:26:04 UTC 2016
+# Sun Jun 26 07:42:09 UTC 2016
pkgbase = augeas-git
- pkgdesc = %%SOME DESCRIPTION HERE%%
- pkgver = 0.0.00001
+ pkgdesc = A configuration editing tool that parses config files and transforms them into a tree (Git checkout)
+ pkgver = r2665.6418925
pkgrel = 1
- url = %%SOME URL HERE%%
+ url = http://augeas.net
arch = i686
arch = x86_64
- license = %%SOME LICENSE(S) HERE%%
+ license = LGPL
+ depends = libxml2
+ depends = gcc-libs
provides = augeas
- source = augeas::git+https://github.com/augeas/augeas.git
+ conflicts = augeas
+ source = augeas::git+https://github.com/hercules-team/augeas.git
sha512sums = SKIP
pkgname = augeas-git
diff --git a/PKGBUILD b/PKGBUILD
index 8fe9e73df4f1..b8cabe535463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
+# News updates for packages can be followed at https://devblog.square-r00t.net
+# Many thanks to the PKGBUILD for augeas (currently in [Community]) and the
+# respective contributors and maintainer(s).
validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
pkgname=augeas-git
-pkgver=0.0.00001
+pkgver=r2665.6418925
pkgrel=1
-pkgdesc="%%SOME DESCRIPTION HERE%%"
+pkgdesc="A configuration editing tool that parses config files and transforms them into a tree (Git checkout)"
arch=('i686' 'x86_64')
-url="%%SOME URL HERE%%"
-license=('%%SOME LICENSE(S) HERE%%')
+url="http://augeas.net"
+license=('LGPL')
install=
changelog=
noextract=()
-#depends=('%%RUNTIME DEPENDENCIES HERE%%')
-#optdepends=('%%OPTIONAL DEPENDENCIES HERE (pkg: why needed)%%')
-#makedepends=('%%BUILDTIME DEPENDENCIES HERE%%')
+depends=('libxml2' 'gcc-libs')
+# optional, as the autogen.sh pulls in a copy. however, if you uncomment this line below, switch make lines below. untested.
+#makedepends=('gnulib-git')
_pkgname=augeas
-#_pkgname2='%%OPTIONAL SHORTHAND PACKAGE NAME%%'
-source=("${_pkgname}::git+https://github.com/${_pkgname}/${_pkgname}.git")
+source=("${_pkgname}::git+https://github.com/hercules-team/${_pkgname}.git")
sha512sums=('SKIP')
provides=("${_pkgname}")
-#conflicts=("${_pkgname}")
+conflicts=("${_pkgname}")
pkgver() {
cd "${srcdir}/${_pkgname}"
(
@@ -31,11 +34,15 @@ pkgver() {
}
build() {
- cd "${srcdir}/${_pkgname}/src"
- make prefix=${pkgdir}/usr
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh
+ sed -i 's|Requires:.*|Requires: libxml-2.0|' augeas.pc.in
+ ./configure --prefix=/usr
+ make
+ # make --gnulib-srcdir=/usr/share/gnulib
}
package() {
- install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname2} ${pkgdir}/usr/bin/${_pkgname2}
- install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+ cd ${srcdir}/${_pkgname}
+ make DESTDIR="${pkgdir}" install
}