summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Kunze2016-05-11 20:14:29 +0200
committerTobias Kunze2016-05-11 20:14:29 +0200
commitee433848689d8a7a0c104b9d04096810b0c5734d (patch)
treea2ec3a3a85f376724466050e96c95581d33a9afa
downloadaur-ee433848689d8a7a0c104b9d04096810b0c5734d.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
-rw-r--r--augenkrebs.install14
-rw-r--r--augenkrebs.service17
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67ae61784bd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = augenkrebs-git
+ pkgdesc = Control VLC playback via a web interface. Internetabspielgerät @shackspace.
+ pkgver = v0.3.r0.g7d54496
+ pkgrel = 1
+ url = http://github.com/shackspace/augenkrebs/
+ install = augenkrebs.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-flask
+ depends = vlc
+ depends = ttf-freefont
+ depends = chromium
+ source = augenkrebs-git::git://github.com/shackspace/augenkrebs.git
+ md5sums = SKIP
+
+pkgname = augenkrebs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cd19250a3a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: rixx <rixx-aur@cutebit.de>
+
+pkgname=augenkrebs-git
+pkgver=v0.3.r0.g7d54496
+pkgrel=1
+pkgdesc="Control VLC playback via a web interface. Internetabspielgerät @shackspace."
+arch=('any')
+url="http://github.com/shackspace/augenkrebs/"
+license=('MIT')
+groups=()
+depends=('python' 'python-flask' 'vlc' 'ttf-freefont' 'chromium')
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install='augenkrebs.install'
+source=("$pkgname"::'git://github.com/shackspace/augenkrebs.git')
+noextract=()
+md5sums=('SKIP') #generate with 'makepkg -g'
+
+_gitroot='http://github.com/shackspace/augenkrebs.git'
+_gitname='augenkrebs'
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ mkdir -p ${pkgdir}/usr/lib/
+ cp -r augenkrebs "$pkgdir"/usr/lib/
+ chmod -R a+rX "$pkgdir"/usr/lib/augenkrebs
+
+ install -Dm644 install/augenkrebs.service "$pkgdir"/usr/lib/systemd/system/augenkrebs.service
+
+ mkdir -p ${pkgdir}/usr/bin
+ chmod +x ${pkgdir}/usr/lib/augenkrebs/augenkrebs.py
+ ln -s /usr/lib/augenkrebs/augenkrebs.py ${pkgdir}/usr/bin/augenkrebs
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/augenkrebs.install b/augenkrebs.install
new file mode 100644
index 000000000000..31c7766d1fa2
--- /dev/null
+++ b/augenkrebs.install
@@ -0,0 +1,14 @@
+post_install(){
+ echo "Creating user augenkrebs for use with the systemd service"
+ useradd -u 42 -m augenkrebs &>/dev/null
+ echo "If you want to use the systemd service in /usr/lib/systemd/system,"
+ echo "please edit it beforehand to include the log in manager of your"
+ echo "choice as target. "
+ echo "You will also probably need to create and edit the X startup file"
+ echo "of the augenkrebs user."
+}
+
+post_remove(){
+ userdel augenkrebs &>/dev/null
+}
+
diff --git a/augenkrebs.service b/augenkrebs.service
new file mode 100644
index 000000000000..6c1a384e1d1e
--- /dev/null
+++ b/augenkrebs.service
@@ -0,0 +1,17 @@
+[Unit]
+Description=augenkrebs server
+After=network.target
+#After=slim.target
+# ^replace by the X target of your choice
+
+[Service]
+Type=simple
+User=augenkrebs
+ExecStart=/usr/bin/augenkrebs
+Environment=DISPLAY=:0
+
+# Give a reasonable amount of time for the server to start up/shut down
+TimeoutSec=300
+
+[Install]
+WantedBy=graphical.target