summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2020-06-10 23:59:04 +0200
committermschubert2020-06-10 23:59:04 +0200
commit41b27598b8bf8464929e090c69647287ebb52a5e (patch)
tree8abd80a90b3e75a179ed29a8b61985ad30f25b36
parent0d40ece0f10dcd74c0f360a816a7e7b1e1eaba4e (diff)
downloadaur-41b27598b8bf8464929e090c69647287ebb52a5e.tar.gz
version bump 3.3.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD41
2 files changed, 23 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95dc5a6c658f..c8102287088d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = augustus
pkgdesc = A eucaryotic gene prediction program
- pkgver = 2.5.5
+ pkgver = 3.3.3
pkgrel = 1
url = http://augustus.gobics.de/
arch = i686
arch = x86_64
license = custom:Artistic-2.0
- depends = perl
+ depends = samtools
+ depends = htslib
+ depends = bamtools
options = !strip
- source = http://augustus.gobics.de/binaries/augustus.2.5.5.tar.gz
- source = http://augustus.gobics.de/binaries/LICENCE.TXT
- md5sums = 234adc8fe4c2ff0b70715fbf00173668
- md5sums = 7e2216d2af60d1644c220cbad40b0e36
+ source = augustus-3.3.3.tar.gz::https://github.com/Gaius-Augustus/Augustus/archive/v3.3.3.tar.gz
+ sha256sums = 2fc5f9fd2f0c3bba2924df42ffaf55b5c130228cea18efdb3b6dfab9efa8c9f4
pkgname = augustus
diff --git a/PKGBUILD b/PKGBUILD
index 92b7a09773b4..5fdf39488d0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,30 @@
-# Maintainer: Michael Schubert <mschu.dev at google mail>
+# Maintainer: Michael Schubert <mschu.dev at gmail>
pkgname=augustus
-pkgver=2.5.5
+_pkgname=Augustus
+pkgver=3.3.3
pkgrel=1
pkgdesc="A eucaryotic gene prediction program"
arch=('i686' 'x86_64')
url="http://augustus.gobics.de/"
license=('custom:Artistic-2.0')
-depends=('perl')
-source=("http://augustus.gobics.de/binaries/$pkgname.$pkgver.tar.gz"
- "http://augustus.gobics.de/binaries/LICENCE.TXT")
-md5sums=('234adc8fe4c2ff0b70715fbf00173668'
- '7e2216d2af60d1644c220cbad40b0e36')
+depends=('samtools' 'htslib' 'bamtools')
+source=($pkgname-$pkgver.tar.gz::https://github.com/Gaius-Augustus/Augustus/archive/v$pkgver.tar.gz)
+sha256sums=('2fc5f9fd2f0c3bba2924df42ffaf55b5c130228cea18efdb3b6dfab9efa8c9f4')
options=(!strip)
+prepare() {
+ cd $_pkgname-$pkgver
+ sed -i "/\/usr\/local\/bin/d" Makefile
+ sed -i "/bam2wig/d" auxprogs/Makefile # requires special dir structure of util
+}
+
build() {
- cd $pkgname.$pkgver
- make all
+ cd $_pkgname-$pkgver
+ make SAMTOOLS=/usr/include/bam
}
package() {
- cd $pkgname.$pkgver
-
- mkdir -p "$pkgdir/usr/share/augustus/scripts"
- mkdir -p "$pkgdir/etc/"{augustus,profile.d}
-
- cp -R bin "$pkgdir/usr/"
- cp -R config "$pkgdir/etc/augustus/"
- cp -R {docs,examples} "$pkgdir/usr/share/augustus/"
- cp scripts/*.pl "$pkgdir/usr/share/augustus/scripts/"
-
- echo export AUGUSTUS_CONFIG_PATH="/etc/augustus/config/" > "$pkgdir/etc/profile.d/augustus.sh"
- chmod a+rx "$pkgdir/etc/profile.d/augustus.sh"
-
- install -Dm644 "$srcdir/LICENCE.TXT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd $_pkgname-$pkgver
+ make INSTALLDIR="$pkgdir" install
+ install -Dm644 src/LICENSE.TXT "$pkgdir"/usr/share/licenses/augustus/LICENSE
}
-