summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lercher2021-08-07 23:31:12 +0200
committerThomas Lercher2021-08-07 23:31:12 +0200
commit0b59ecd21aadd64a97055d84257bcc970079436c (patch)
treee1e7c0b4800adf27e60ea9d86188196a49a6aba1
parent2c317f83d9f8d4e5b9ab5f342f08aa5fc21d4282 (diff)
downloadaur-0b59ecd21aadd64a97055d84257bcc970079436c.tar.gz
Update to v3.0.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
-rw-r--r--augustus-game.install16
3 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f3cb8b71fdd..6f103adf134f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = augustus-game
pkgdesc = An enhanced re-implementation of Caesar III (Original copy required)
- pkgver = 2.0.1
- pkgrel = 2
+ pkgver = 3.0.1
+ pkgrel = 1
url = https://github.com/Keriew/augustus
install = augustus-game.install
arch = i686
@@ -13,10 +13,9 @@ pkgbase = augustus-game
depends = libpng
source = augustus-game.desktop
source = augustus-game.install
- source = https://github.com/Keriew/augustus/archive/v2.0.1.tar.gz
+ source = https://github.com/Keriew/augustus/archive/v3.0.1.tar.gz
sha256sums = 52fd21bbd8a32cee21399c598283dfea11fa507e01e92c8344fb6e021fae0928
- sha256sums = 95793de9019c9343e39add889f3efab5833702f068d39b4c727b2f8ae92e093c
- sha256sums = 9210b6123989554a22f39b4b53bb25d2f75407355cfc2a8b28a788df967a03ea
+ sha256sums = d0d9e1fdfa9edbb22239d55612c8b7ffdb501a1cfebea82cce2ccf4259f867ef
+ sha256sums = 3452ff516f1006e48036925a3f815329cce6e90d8848e44a90ea7ce120169eb2
pkgname = augustus-game
-
diff --git a/PKGBUILD b/PKGBUILD
index ffaa69ec1f9f..f9c69e8cb038 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=augustus
pkgname=$_pkgname-game
-pkgver=2.0.1
-pkgrel=2
+pkgver=3.0.1
+pkgrel=1
pkgdesc="An enhanced re-implementation of Caesar III (Original copy required)"
arch=('i686' 'x86_64')
url="https://github.com/Keriew/augustus"
@@ -14,8 +14,8 @@ depends=('sdl2' 'sdl2_mixer' 'libpng')
install="${pkgname}.install"
source=(${pkgname}.desktop ${pkgname}.install $url/archive/v$pkgver.tar.gz)
sha256sums=('52fd21bbd8a32cee21399c598283dfea11fa507e01e92c8344fb6e021fae0928'
- '03467d55f4314a46ad3c8e6b16e689f36772969c42869823c175b01e6f6392c7'
- '9210b6123989554a22f39b4b53bb25d2f75407355cfc2a8b28a788df967a03ea')
+ 'd0d9e1fdfa9edbb22239d55612c8b7ffdb501a1cfebea82cce2ccf4259f867ef'
+ '3452ff516f1006e48036925a3f815329cce6e90d8848e44a90ea7ce120169eb2')
build() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -33,8 +33,8 @@ package() {
# Install additional folders to /opt
install -m 775 -d "${pkgdir}/opt/${pkgname}"
- install -m 775 -d "${pkgdir}/opt/${pkgname}/mods"
+ install -m 775 -d "${pkgdir}/opt/${pkgname}/assets"
install -m 775 -d "${pkgdir}/opt/${pkgname}/res/maps"
- cp -r "$srcdir/$_pkgname-$pkgver/mods" "${pkgdir}/opt/${pkgname}/"
+ cp -r "$srcdir/$_pkgname-$pkgver/assets" "${pkgdir}/opt/${pkgname}/"
cp -r "$srcdir/$_pkgname-$pkgver/res/maps" "${pkgdir}/opt/${pkgname}/res/"
}
diff --git a/augustus-game.install b/augustus-game.install
index 685a0cf01032..8162b824d690 100644
--- a/augustus-game.install
+++ b/augustus-game.install
@@ -3,14 +3,14 @@ post_install() {
echo "
augustus also requires additional folders/files to be installed to your Caesar III installation.
-The easiest way is to symlink the 'maps' and 'mods' folder from '/opt/augustus-game'
+The easiest way is to symlink the 'maps' and 'assets' folder from '/opt/augustus-game'
into the root of your Caesar III installation.
If you are in your Caesar III installation folder
you can copy & paste the following lines to symlink them (depending on your shell):
ln -s /opt/augustus-game/res/maps .
- ln -s /opt/augustus-game/mods .
+ ln -s /opt/augustus-game/assets .
For further information and how to add high-quality MP3 music/sounds to your installation see:
@@ -18,8 +18,18 @@ For further information and how to add high-quality MP3 music/sounds to your ins
"
}
+post_upgrade() {
+ echo "
+Augustus renamed the 'mods' folder to 'assets', please check your Caesar III installation.
+
+If there is an 'mods' folder, please unlink it and link the assets folder from /opt into it:
+
+ ln -s /opt/augustus-game/assets .
+"
+}
+
post_remove() {
echo "
-Don't forget to remove/unlink the 'maps' and 'mods' folder from your Caesar III installation.
+Don't forget to remove/unlink the 'maps' and 'assets' folder from your Caesar III installation.
"
}