summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lercher2020-07-12 22:18:05 +0200
committerThomas Lercher2020-07-12 22:18:05 +0200
commit2e2c84436307018c6025d68960bdc023c70220de (patch)
treee659a592dfbfbfe2a871c85ed20f7af31b685262
downloadaur-2e2c84436307018c6025d68960bdc023c70220de.tar.gz
Add current version of augustus (v1.4.1a) to AUR
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--augustus-game.desktop11
-rw-r--r--augustus-game.install3
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9483e8d7415d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = augustus-game
+ pkgdesc = An enhanced re-implementation of Caesar III (Original copy required)
+ pkgver = 1.4.1a
+ pkgrel = 1
+ url = https://github.com/Keriew/augustus
+ install = augustus-game.install
+ arch = i686
+ arch = x86_64
+ license = AGPL
+ makedepends = cmake
+ depends = sdl2
+ depends = sdl2_mixer
+ source = augustus-game.desktop
+ source = augustus-game.install
+ source = https://github.com/Keriew/augustus/archive/v1.4.1a.tar.gz
+ sha256sums = 52fd21bbd8a32cee21399c598283dfea11fa507e01e92c8344fb6e021fae0928
+ sha256sums = a13556dff5011df049ec64964db94f6cfcdc0e5fb18801e190af0a95b840af75
+ sha256sums = ab0f75357b07b9183d3f09a92c759f8c7016bc8ac24a3d45b0b42a63dd9b4a42
+
+pkgname = augustus-game
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b254441fc822
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Thomas Lercher <aur@tlercher.de>
+# Contributor: NiNjA <heinep at gmail dot com>
+
+_pkgname=augustus
+pkgname=$_pkgname-game
+pkgver=1.4.1a
+pkgrel=1
+pkgdesc="An enhanced re-implementation of Caesar III (Original copy required)"
+arch=('i686' 'x86_64')
+url="https://github.com/Keriew/augustus"
+license=('AGPL')
+makedepends=('cmake')
+depends=('sdl2' 'sdl2_mixer')
+install="$pkgname.install"
+source=($pkgname.desktop $pkgname.install $url/archive/v$pkgver.tar.gz)
+sha256sums=('52fd21bbd8a32cee21399c598283dfea11fa507e01e92c8344fb6e021fae0928'
+ 'a13556dff5011df049ec64964db94f6cfcdc0e5fb18801e190af0a95b840af75'
+ 'ab0f75357b07b9183d3f09a92c759f8c7016bc8ac24a3d45b0b42a63dd9b4a42')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ cmake .
+ make
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname-$pkgver/$_pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/$_pkgname-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ #install -Dm664 "$srcdir/$_pkgname-$pkgver/res/julius_48.png" "$pkgdir/usr/share/pixmaps/${pkgname}48.png"
+ #install -Dm664 "$srcdir/$_pkgname-$pkgver/res/julius_256.png" "$pkgdir/usr/share/pixmaps/${pkgname}256.png"
+ install -Dm664 "$srcdir/$_pkgname-$pkgver/res/julius_512.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+ install -Dm664 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
diff --git a/augustus-game.desktop b/augustus-game.desktop
new file mode 100644
index 000000000000..28bc566292af
--- /dev/null
+++ b/augustus-game.desktop
@@ -0,0 +1,11 @@
+# http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-1.0.html
+[Desktop Entry]
+Type=Application
+Version=1.0
+Exec=augustus-game
+Icon=augustus-game
+Name=Augustus
+GenericName=Roman city management game
+Comment=Open Source re-implementation of Caesar 3.
+Categories=Game;Simulation;
+
diff --git a/augustus-game.install b/augustus-game.install
new file mode 100644
index 000000000000..99271fff96de
--- /dev/null
+++ b/augustus-game.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo ">> augustus requires a copy of the original Caesar III. The binary will ask for game directory on first start."
+}