summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-07-11 08:10:04 +0300
committerMr.Smith19742023-07-11 08:10:04 +0300
commitd2dbb30a1a32d2bca85def58570ed8ad93f5c950 (patch)
treeeb2afb0b6aba9f65dd64c8460e86cab96a268982
downloadaur-d2dbb30a1a32d2bca85def58570ed8ad93f5c950.tar.gz
Initial build
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24d3cb46d621
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = augustus-game-appimage
+ pkgdesc = An enhanced re-implementation of Caesar III (Original copy required). Appimage version
+ pkgver = 3.2.0
+ pkgrel = 1
+ url = https://github.com/Keriew/augustus
+ arch = x86_64
+ license = AGPL
+ depends = fuse2
+ conflicts = augustus-game
+ conflicts = augustus-game-git
+ options = !strip
+ source = https://github.com/Keriew/augustus/releases/download/v3.2.0/augustus-3.2.0-linux.AppImage
+ sha256sums = e973adfc01db2dd03637dd22f6b3ecc578a604bf4e761582d6f6eb243f995be0
+
+pkgname = augustus-game-appimage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a94e5f729c4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+_pkgname=augustus
+_pkgver=3.2.0
+_appimage="${_pkgname}-${_pkgver}-linux.AppImage"
+_desktopfile="com.github.keriew.augustus"
+
+pkgname=augustus-game-appimage
+pkgver="${_pkgver}"
+pkgrel=1
+pkgdesc="An enhanced re-implementation of Caesar III (Original copy required). Appimage version"
+arch=(x86_64)
+license=(AGPL)
+url="https://github.com/Keriew/augustus"
+depends=('fuse2')
+conflicts=('augustus-game' 'augustus-game-git')
+options=(!strip)
+source=("https://github.com/Keriew/augustus/releases/download/v${pkgver}/${_appimage}")
+sha256sums=('e973adfc01db2dd03637dd22f6b3ecc578a604bf4e761582d6f6eb243f995be0')
+
+
+prepare() {
+ chmod +x ${_appimage}
+ ./${_appimage} --appimage-extract ${_desktopfile}.desktop
+ ./${_appimage} --appimage-extract usr/share/icons/hicolor/512x512/apps/${_desktopfile}.png
+}
+
+package() {
+ install -Dpm755 "${_appimage}" "${pkgdir}/opt/${_pkgname}/${_appimage}" # Install $_appimage to /opt/$_pkgname/$_appimage
+ install -d "${pkgdir}/usr/bin" # Install /usr/bin
+ ln -s "/opt/${_pkgname}/${_appimage}" "${pkgdir}/usr/bin/${_pkgname}" # Link /opt/$_pkgname/$_appimage to /usr/bin/$_pkgname
+
+ # Desktop file
+ install -dm755 "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/squashfs-root/${_desktopfile}.desktop" "${pkgdir}/usr/share/applications"
+
+ # Icon images
+ install -dm755 "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/512x512/apps/${_desktopfile}.png" "${pkgdir}/usr/share/pixmaps"
+}
+