summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lercher2020-12-24 04:03:16 +0100
committerThomas Lercher2020-12-24 04:03:16 +0100
commit272b983373667419e23e9ad286ce2b1f0990b62e (patch)
tree7723a9f302d75a235273bdaa2cc5a2f644d2eb17
parent27fb9e19fc472008d443027d11924782ab4b72ef (diff)
downloadaur-272b983373667419e23e9ad286ce2b1f0990b62e.tar.gz
Added support for the required 'mods' and 'maps' folders
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD28
-rw-r--r--augustus-game.desktop11
-rw-r--r--augustus-game.install22
4 files changed, 56 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f72094cb01fb..9dd5f5fbb155 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = augustus-game-git
pkgdesc = An enhanced re-implementation of Caesar III (Original copy required)
- pkgver = r2389.c06d5257
+ pkgver = r2924.e061e632
pkgrel = 1
url = https://github.com/Keriew/augustus
arch = i686
@@ -10,11 +10,14 @@ pkgbase = augustus-game-git
makedepends = cmake
depends = sdl2
depends = sdl2_mixer
+ depends = libpng
provides = augustus-game
conflicts = augustus-game
+ source = augustus-game.desktop
source = augustus-game.install
source = git+https://github.com/Keriew/augustus
- sha256sums = a13556dff5011df049ec64964db94f6cfcdc0e5fb18801e190af0a95b840af75
+ sha256sums = 52fd21bbd8a32cee21399c598283dfea11fa507e01e92c8344fb6e021fae0928
+ sha256sums = 03467d55f4314a46ad3c8e6b16e689f36772969c42869823c175b01e6f6392c7
sha256sums = SKIP
pkgname = augustus-game-git
diff --git a/PKGBUILD b/PKGBUILD
index 2dc086d8072f..c4186a4ec02e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=augustus
pkgname=$_pkgname-game-git
pkgdesc="An enhanced re-implementation of Caesar III (Original copy required)"
-pkgver=r2389.c06d5257
+pkgver=r2924.e061e632
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/Keriew/augustus"
@@ -12,9 +12,10 @@ license=('AGPL')
conflicts=('augustus-game')
provides=('augustus-game')
makedepends=('git' 'cmake')
-depends=('sdl2' 'sdl2_mixer')
-source=($_pkgname-game.install git+https://github.com/Keriew/augustus)
-sha256sums=('a13556dff5011df049ec64964db94f6cfcdc0e5fb18801e190af0a95b840af75'
+depends=('sdl2' 'sdl2_mixer' 'libpng')
+source=($_pkgname-game.desktop $_pkgname-game.install git+https://github.com/Keriew/augustus)
+sha256sums=('52fd21bbd8a32cee21399c598283dfea11fa507e01e92c8344fb6e021fae0928'
+ '03467d55f4314a46ad3c8e6b16e689f36772969c42869823c175b01e6f6392c7'
'SKIP')
pkgver() {
@@ -30,13 +31,20 @@ build() {
mkdir -p build && cd build
cmake ..
make
- cp ../res/${_pkgname}.desktop .
- sed -i 's/Exec=augustus/Exec=augustus-game/' ${_pkgname}.desktop
}
package() {
- install -Dm755 "$srcdir/${_pkgname}/build/${_pkgname}" "$pkgdir/usr/bin/${_pkgname}-game"
- install -Dm644 "$srcdir/${_pkgname}/LICENSE.txt" "$pkgdir/usr/share/licenses/${_pkgname}-game/LICENSE"
- install -Dm664 "$srcdir/${_pkgname}/res/${_pkgname}_512.png" "$pkgdir/usr/share/pixmaps/com.github.keriew.augustus.png"
- install -Dm664 "$srcdir/${_pkgname}/build/${_pkgname}.desktop" "$pkgdir/usr/share/applications/${_pkgname}-game.desktop"
+ install -Dm755 "$srcdir/${_pkgname}/build/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}-game"
+ install -Dm644 "$srcdir/${_pkgname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${_pkgname}-game/LICENSE"
+ install -Dm664 "$srcdir/${_pkgname}/res/${_pkgname}_48.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}_game48.png"
+ install -Dm664 "$srcdir/${_pkgname}/res/${_pkgname}_256.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}_game256.png"
+ install -Dm664 "$srcdir/${_pkgname}/res/${_pkgname}_512.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}-game.png"
+ install -Dm664 "${_pkgname}-game.desktop" "${pkgdir}/usr/share/applications/${_pkgname}-game.desktop"
+
+ # Install additional folders to /opt
+ install -m 775 -d "${pkgdir}/opt/${_pkgname}-game"
+ install -m 775 -d "${pkgdir}/opt/${_pkgname}-game/mods"
+ install -m 775 -d "${pkgdir}/opt/${_pkgname}-game/res/maps"
+ cp -r "$srcdir/${_pkgname}/mods" "${pkgdir}/opt/${_pkgname}-game/"
+ cp -r "$srcdir/${_pkgname}/res/maps" "${pkgdir}/opt/${_pkgname}-game/res/"
}
diff --git a/augustus-game.desktop b/augustus-game.desktop
new file mode 100644
index 000000000000..28bc566292af
--- /dev/null
+++ b/augustus-game.desktop
@@ -0,0 +1,11 @@
+# http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-1.0.html
+[Desktop Entry]
+Type=Application
+Version=1.0
+Exec=augustus-game
+Icon=augustus-game
+Name=Augustus
+GenericName=Roman city management game
+Comment=Open Source re-implementation of Caesar 3.
+Categories=Game;Simulation;
+
diff --git a/augustus-game.install b/augustus-game.install
index 99271fff96de..685a0cf01032 100644
--- a/augustus-game.install
+++ b/augustus-game.install
@@ -1,3 +1,25 @@
post_install() {
echo ">> augustus requires a copy of the original Caesar III. The binary will ask for game directory on first start."
+
+ echo "
+augustus also requires additional folders/files to be installed to your Caesar III installation.
+The easiest way is to symlink the 'maps' and 'mods' folder from '/opt/augustus-game'
+into the root of your Caesar III installation.
+
+If you are in your Caesar III installation folder
+you can copy & paste the following lines to symlink them (depending on your shell):
+
+ ln -s /opt/augustus-game/res/maps .
+ ln -s /opt/augustus-game/mods .
+
+
+For further information and how to add high-quality MP3 music/sounds to your installation see:
+ https://github.com/Keriew/augustus/blob/master/doc/RUNNING.md
+"
+}
+
+post_remove() {
+ echo "
+Don't forget to remove/unlink the 'maps' and 'mods' folder from your Caesar III installation.
+"
}