summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lercher2020-07-15 00:58:42 +0200
committerThomas Lercher2020-07-15 00:58:42 +0200
commit9a9cc2a14a8b3cbb65d20a9c57b29241d82888cc (patch)
treee6a3bda5b6ee3bab3d6a2629417d5c69d4b466b0
downloadaur-9a9cc2a14a8b3cbb65d20a9c57b29241d82888cc.tar.gz
Add initial version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
-rw-r--r--augustus-game.install3
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c7b23436818
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = augustus-game-git
+ pkgdesc = An enhanced re-implementation of Caesar III (Original copy required)
+ pkgver = r2357.f83dee2f
+ pkgrel = 1
+ url = https://github.com/Keriew/augustus
+ arch = i686
+ arch = x86_64
+ license = AGPL
+ makedepends = git
+ makedepends = cmake
+ depends = sdl2
+ depends = sdl2_mixer
+ provides = augustus-game
+ conflicts = augustus-game
+ source = augustus-game.install
+ source = git+https://github.com/Keriew/augustus
+ sha256sums = a13556dff5011df049ec64964db94f6cfcdc0e5fb18801e190af0a95b840af75
+ sha256sums = SKIP
+
+pkgname = augustus-game-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08c4a89e551f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Thomas Lercher <aur@tlercher.de>
+# Contributor: NiNjA <heinep at gmail dot com>
+
+_pkgname=augustus
+pkgname=$_pkgname-game-git
+pkgdesc="An enhanced re-implementation of Caesar III (Original copy required)"
+pkgver=r2357.f83dee2f
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/Keriew/augustus"
+license=('AGPL')
+conflicts=('augustus-game')
+provides=('augustus-game')
+makedepends=('git' 'cmake')
+depends=('sdl2' 'sdl2_mixer')
+source=($_pkgname-game.install git+https://github.com/Keriew/augustus)
+sha256sums=('a13556dff5011df049ec64964db94f6cfcdc0e5fb18801e190af0a95b840af75'
+ 'SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ mkdir -p build && cd build
+ cmake ..
+ make
+ cp ../res/${_pkgname}.desktop .
+ sed -i 's/Exec=julius/Exec=augustus-game/' ${_pkgname}.desktop
+}
+
+package() {
+ install -Dm755 "$srcdir/${_pkgname}/build/${_pkgname}" "$pkgdir/usr/bin/${_pkgname}-game"
+ install -Dm644 "$srcdir/${_pkgname}/LICENSE.txt" "$pkgdir/usr/share/licenses/${_pkgname}-game/LICENSE"
+ install -Dm664 "$srcdir/${_pkgname}/res/${_pkgname}_512.png" "$pkgdir/usr/share/pixmaps/com.github.keriew.augustus.png"
+ install -Dm664 "$srcdir/${_pkgname}/build/${_pkgname}.desktop" "$pkgdir/usr/share/applications/${_pkgname}-game.desktop"
+}
diff --git a/augustus-game.install b/augustus-game.install
new file mode 100644
index 000000000000..99271fff96de
--- /dev/null
+++ b/augustus-game.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo ">> augustus requires a copy of the original Caesar III. The binary will ask for game directory on first start."
+}