summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlberto Salvia Novella2019-11-02 21:54:22 +0100
committerAlberto Salvia Novella2019-11-02 21:54:22 +0100
commit3c6ab6ae5353bd2d68591b7e6f9ce465c905fc86 (patch)
tree7b8a9f2673579a540fb30e6bc436c748d988d685
downloadaur-3c6ab6ae5353bd2d68591b7e6f9ce465c905fc86.tar.gz
2019-11-02 1572728062
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD43
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb95152fe160
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = aur-box
+ pkgdesc = Publishes software instantly to Arch Linuxes
+ pkgver = 12
+ pkgrel = 1
+ url = https://gitlab.com/es20490446e/aur-box
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = curl
+ depends = silently
+ provides = aur
+ provides = aur-publisher
+ provides = aur-box
+ conflicts = aur
+ conflicts = aur-publisher
+ conflicts = aur-box
+ replaces = aur
+ replaces = aur-publisher
+ source = git+https://gitlab.com/es20490446e/aur-box.git
+ md5sums = SKIP
+
+pkgname = aur-box
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d22795558c77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+#! /bin/bash
+# Coding manual at: https://gitlab.com/es20490446e/aur-box/wikis/packaging
+
+Name="aur-box"
+provides=("aur" "aur-publisher" "${Name}")
+conflicts=("aur" "aur-publisher" "${Name}")
+replaces=("aur" "aur-publisher")
+pkgname="${Name}"
+
+arch=("x86_64")
+pkgver=12
+pkgrel=1
+
+pkgdesc="Publishes software instantly to Arch Linuxes"
+license=("GPL3")
+url="https://gitlab.com/es20490446e/${Name}"
+
+makedepends=("git")
+depends=("curl" "silently")
+
+source=("git+${url}.git")
+md5sums=("SKIP")
+
+
+pkgver () {
+ cd "${Name}"
+ git rev-list --count HEAD
+}
+
+
+package () {
+ mkdir --parents "${pkgdir}/usr/bin"
+ mkdir --parents "${pkgdir}/usr/share/man/man1"
+
+ mv "${srcdir}/${Name}/assets/box" "${pkgdir}/usr/share/box"
+ mv "${srcdir}/${Name}/assets/box.1" "${pkgdir}/usr/share/man/man1/box.1"
+ ln --symbolic "/usr/share/box/_box" "${pkgdir}/usr/bin/box"
+
+ find "${pkgdir}" -type d -exec chmod u=rwx,g=rx,o=rx {} \;
+ find "${pkgdir}" -type f -exec chmod u=rw,g=r,o=r {} \;
+ chmod u=rwx,g=rx,o=rx "${pkgdir}/usr/share/box/_box"
+}
+