summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2022-12-09 20:01:50 -0500
committeréclairevoyant2022-12-09 20:01:50 -0500
commit166072eab8bc06fe23dd22b7153149a7c90aba92 (patch)
treea4b74b6179d7bf6cca09c2ccbf3575ac02e06254
parentc48f2339c532a92f95d548c44365f16cf62c2679 (diff)
downloadaur-comment-fetcher-git.tar.gz
aur-comment-fetcher-git: update git source
add .gitignore Signed-off-by: éclairevoyant <848000+eclairevoyant@users.noreply.github.com>
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85de558f9cf0..3ccc042c094c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aur-comment-fetcher-git
pkgdesc = A simple script fetching the comments of packages in AUR
- pkgver = r20.c3f0e12
+ pkgver = r30.afef23d
pkgrel = 1
url = https://github.com/mortbauer/aur-comment-fetcher
arch = any
@@ -12,9 +12,7 @@ pkgbase = aur-comment-fetcher-git
depends = python-lxml
depends = python3-aur
provides = aur-comment-fetcher
- conflicts = aur-comment-fetcher
- source = git://github.com/mortbauer/aur-comment-fetcher.git
+ source = git+https://github.com/mortbauer/aur-comment-fetcher.git
sha256sums = SKIP
pkgname = aur-comment-fetcher-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 62b0dd11a2c4..ee5471fd7d31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,29 @@
-# Maintainer: Maxim Andersson <thesilentboatman@gmail.com>
+# Maintainer: éclairevoyant
+# Contributor: Maxim Andersson <thesilentboatman@gmail.com>
# Contributor: Martin Ortbauer <mortbauer@gmail.com>
-pkgname=aur-comment-fetcher-git
-_gitname=aur-comment-fetcher
-pkgver=r20.c3f0e12
+_pkgname=aur-comment-fetcher
+pkgname="$_pkgname-git"
+pkgver=r30.afef23d
pkgrel=1
pkgdesc="A simple script fetching the comments of packages in AUR"
arch=('any')
-url="https://github.com/mortbauer/aur-comment-fetcher"
+url="https://github.com/mortbauer/$_pkgname"
license=('GPL')
depends=('python-click' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python3-aur')
makedepends=('git')
-provides=('aur-comment-fetcher')
-conflicts=('aur-comment-fetcher')
-source=('git://github.com/mortbauer/aur-comment-fetcher.git')
+provides=("$_pkgname")
+source=("git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_gitname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "${srcdir}/${_gitname}"
-
- install -D aur-comment-fetch -t "${pkgdir}/usr/bin"
- install -Dm644 bash_completion "${pkgdir}/usr/share/bash-completion/completions/aur-comment-fetch"
+ cd $_pkgname
+ _binname=aur-comment-fetch
+ install -Dm755 $_binname -t "$pkgdir/usr/bin/"
+ install -Dm644 bash_completion "$pkgdir/usr/share/bash-completion/completions/$_binname"
}
-
-# vim:set ts=2 sw=2 et: