summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2018-02-06 21:53:32 +0100
committerSimon Legner2018-02-06 21:54:51 +0100
commit91bcb3a8ab5e18fbc6651b13d4d4b9d07e7a284e (patch)
treec169f4a3e01deaf0983b155844905001969521cc
parente50e6cd1e0f6f53b1f6951629c7394f57240a01d (diff)
downloadaur-91bcb3a8ab5e18fbc6651b13d4d4b9d07e7a284e.tar.gz
Update to 0.7.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 835fe1f887c4..64d6cc8cf929 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Thu Feb 1 19:20:11 UTC 2018
+# Tue Feb 6 20:54:43 UTC 2018
pkgbase = aur-out-of-date
pkgdesc = Determines out-of-date AUR packages
- pkgver = 0.6.0
- pkgrel = 2
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://github.com/simon04/aur-out-of-date
arch = x86_64
arch = i686
license = GPL
makedepends = go
makedepends = dep
- source = https://github.com/simon04/aur-out-of-date/archive/v0.6.0.tar.gz
- sha256sums = 37458cb6b92cfe8b0f717779d7ba3b9cd4f7520513f3fea60f7d4864b08f083f
+ source = https://github.com/simon04/aur-out-of-date/archive/v0.7.0.tar.gz
+ sha256sums = 2a9ee02a9a14ed5c2ba67fdefaeba02d003483612529a04c7bd032ed95f1e009
pkgname = aur-out-of-date
diff --git a/PKGBUILD b/PKGBUILD
index 71c971c283b7..dfcb86421f86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=aur-out-of-date
-pkgver=0.6.0
-pkgrel=2
+pkgver=0.7.0
+pkgrel=1
pkgdesc="Determines out-of-date AUR packages"
arch=('x86_64' 'i686')
url="https://github.com/simon04/aur-out-of-date"
@@ -15,11 +15,17 @@ prepare() {
export GOPATH="$srcdir/_go"
mkdir -p $(dirname "$GOPATH/src/$_importpath")
ln -sf "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$_importpath"
+ cd "$GOPATH/src/$_importpath"
+ dep ensure
+}
+
+check() {
+ cd "$GOPATH/src/$_importpath"
+ go test $(go list ./...)
}
build() {
cd "$GOPATH/src/$_importpath"
- dep ensure
go build
}
@@ -29,4 +35,4 @@ package() {
install -m755 "$pkgname" "$pkgdir/usr/bin/aur-out-of-date"
}
-sha256sums=('37458cb6b92cfe8b0f717779d7ba3b9cd4f7520513f3fea60f7d4864b08f083f')
+sha256sums=('2a9ee02a9a14ed5c2ba67fdefaeba02d003483612529a04c7bd032ed95f1e009')