summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2018-03-05 12:51:47 +0100
committerSimon Legner2018-03-05 12:51:47 +0100
commit9c6bc442a3ff7a8b1270bb9e9e13d5ebec373fed (patch)
treebb6d4925c36b2dcef5f44a29895874adb3f5ea48
parent528f09325171ce76414d5f653e9ee0b3f49d223a (diff)
downloadaur-9c6bc442a3ff7a8b1270bb9e9e13d5ebec373fed.tar.gz
0.8.0-2: git as makedepends, set GOPATH everywhere
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fea731ea5a8..0952b9b3fd48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Sat Feb 24 21:16:52 UTC 2018
+# Mon Mar 5 11:51:39 UTC 2018
pkgbase = aur-out-of-date
pkgdesc = Determines out-of-date AUR packages
pkgver = 0.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/simon04/aur-out-of-date
arch = x86_64
arch = i686
license = GPL
makedepends = go
makedepends = dep
+ makedepends = git
source = https://github.com/simon04/aur-out-of-date/archive/v0.8.0.tar.gz
sha256sums = ac32e361183cf2c517ee33d8d74e42347dfb6c98d17bf670c73f7269dcbf83e0
diff --git a/PKGBUILD b/PKGBUILD
index 095524b6c5d3..a54ffed1868c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=aur-out-of-date
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Determines out-of-date AUR packages"
arch=('x86_64' 'i686')
url="https://github.com/simon04/aur-out-of-date"
license=('GPL')
source=("https://github.com/simon04/$pkgname/archive/v$pkgver.tar.gz")
-makedepends=('go' 'dep')
+makedepends=('go' 'dep' 'git')
_importpath="github.com/simon04/$pkgname"
@@ -20,16 +20,19 @@ prepare() {
}
check() {
+ export GOPATH="$srcdir/_go"
cd "$GOPATH/src/$_importpath"
go test $(go list ./...)
}
build() {
+ export GOPATH="$srcdir/_go"
cd "$GOPATH/src/$_importpath"
go build
}
package() {
+ export GOPATH="$srcdir/_go"
cd "$GOPATH/src/$_importpath"
install -dm755 "$pkgdir/usr/bin"
install -m755 "$pkgname" "$pkgdir/usr/bin/aur-out-of-date"