summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2018-09-18 10:04:11 +0200
committerSimon Legner2018-09-18 10:04:11 +0200
commitd992d921fef6187fb1c6e353719f7032b4d674d7 (patch)
treefa1a3de7a2ec984391ecdc8696b7b45ef915b48c
parent2740b0bb229ed08b3e6b59d971b274b34535c976 (diff)
downloadaur-d992d921fef6187fb1c6e353719f7032b4d674d7.tar.gz
Update to 2.0.0-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
2 files changed, 12 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6eecfb7eb6fb..1fbf0842de03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = aur-out-of-date
pkgdesc = Determines out-of-date AUR packages
- pkgver = 1.5.0
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/simon04/aur-out-of-date
arch = x86_64
arch = i686
license = GPL
makedepends = go
- makedepends = dep
makedepends = git
- source = aur-out-of-date-1.5.0.tar.gz::https://github.com/simon04/aur-out-of-date/archive/v1.5.0.tar.gz
- sha256sums = a5e9c1321c688b6481569939d97cd8c1516b91e5e139f843323e5bb5701c6754
+ source = aur-out-of-date-2.0.0.tar.gz::https://github.com/simon04/aur-out-of-date/archive/v2.0.0.tar.gz
+ sha256sums = 0f93aa6546762d95ed85dbd2428ddb87c6b8efbc41bd0c5b6f671456d97b6128
pkgname = aur-out-of-date
diff --git a/PKGBUILD b/PKGBUILD
index 845297c5ab4b..ec2028c76482 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,32 @@
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=aur-out-of-date
-pkgver=1.5.0
+pkgver=2.0.0
pkgrel=1
pkgdesc="Determines out-of-date AUR packages"
arch=('x86_64' 'i686')
url="https://github.com/simon04/aur-out-of-date"
license=('GPL')
source=("$pkgname-$pkgver.tar.gz::https://github.com/simon04/$pkgname/archive/v$pkgver.tar.gz")
-makedepends=('go' 'dep' 'git')
-
-_importpath="github.com/simon04/$pkgname"
+makedepends=('go' 'git')
prepare() {
- export GOPATH="$srcdir/_go"
- mkdir -p $(dirname "$GOPATH/src/$_importpath")
- ln -sf "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$_importpath"
- cd "$GOPATH/src/$_importpath"
- dep ensure
+ cd "$srcdir/$pkgname-$pkgver"
+ go mod download
}
check() {
- export GOPATH="$srcdir/_go"
- cd "$GOPATH/src/$_importpath"
+ cd "$srcdir/$pkgname-$pkgver"
go test $(go list ./...)
}
build() {
- export GOPATH="$srcdir/_go"
- cd "$GOPATH/src/$_importpath"
+ cd "$srcdir/$pkgname-$pkgver"
go build
}
package() {
- export GOPATH="$srcdir/_go"
- cd "$GOPATH/src/$_importpath"
- install -dm755 "$pkgdir/usr/bin"
- install -m755 "$pkgname" "$pkgdir/usr/bin/aur-out-of-date"
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/aur-out-of-date"
}
-sha256sums=('a5e9c1321c688b6481569939d97cd8c1516b91e5e139f843323e5bb5701c6754')
+sha256sums=('0f93aa6546762d95ed85dbd2428ddb87c6b8efbc41bd0c5b6f671456d97b6128')