summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2019-02-03 08:45:48 +0100
committerSimon Legner2019-02-03 08:45:48 +0100
commite7de449bffadbdb2ca90389fcdb023aa0103d2b9 (patch)
treec762ea2fc75436e7560e2f4c7f870dba58f51b9d
parentebe99fc793c87c803436c5805b60fe17bf71d761 (diff)
downloadaur-e7de449bffadbdb2ca90389fcdb023aa0103d2b9.tar.gz
2.1.0-2: reproducible builds
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05c30d6a8dd9..d0fcc9368b01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aur-out-of-date
pkgdesc = Determines out-of-date AUR packages
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/simon04/aur-out-of-date
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 78892945825e..963aeb3cc970 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=aur-out-of-date
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Determines out-of-date AUR packages"
arch=('x86_64' 'i686')
url="https://github.com/simon04/aur-out-of-date"
@@ -21,7 +21,10 @@ check() {
build() {
cd "$srcdir/$pkgname-$pkgver"
- go build
+ go build \
+ -gcflags "all=-trimpath=${PWD}" \
+ -asmflags "all=-trimpath=${PWD}" \
+ -ldflags "-extldflags ${LDFLAGS}"
}
package() {