summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGermainZ2018-10-20 19:16:28 +0200
committerGermainZ2018-10-20 19:16:28 +0200
commiteab47f1441aef5da78c1f05f4f3aabe7ef7d4a93 (patch)
treeb21b7d003db779872215cf99360ac5bdddf546c2
downloadaur-eab47f1441aef5da78c1f05f4f3aabe7ef7d4a93.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c33bab94d8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aur-talk-git
+ pkgdesc = A script to fetch and display AUR package comments
+ pkgver = r10.8fcf558
+ pkgrel = 1
+ url = https://github.com/GermainZ/aur-talk
+ arch = any
+ license = custom:ISC
+ makedepends = git
+ depends = python-lxml
+ depends = python-html2text
+ provides = aur-talk
+ conflicts = aur-talk
+ source = git://github.com/GermainZ/aur-talk.git
+ sha256sums = SKIP
+
+pkgname = aur-talk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fe302b30057
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Germain Z. <https://github.com/GermainZ>
+pkgname=aur-talk-git
+_gitname=aur-talk
+pkgver=r10.8fcf558
+pkgrel=1
+pkgdesc="A script to fetch and display AUR package comments"
+arch=('any')
+url="https://github.com/GermainZ/aur-talk"
+license=('custom:ISC')
+depends=('python-lxml' 'python-html2text')
+makedepends=('git')
+provides=('aur-talk')
+conflicts=('aur-talk')
+source=('git://github.com/GermainZ/aur-talk.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_gitname
+ install -Dm755 aur_talk.py "$pkgdir/usr/bin/aur-talk"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}