summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeth Flynn2021-01-18 12:01:47 -0500
committerSeth Flynn2021-01-18 12:01:47 -0500
commitf0cb1928155ec1a88c130e17d545d34a2c453390 (patch)
treeebc0a18ecdd9f8ca26b10bd7f54e23e1d8e6192f
downloadaur-f0cb1928155ec1a88c130e17d545d34a2c453390.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cf6f17569f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = aur-update
+ pkgdesc = automatically update PKGBUILD files for the AUR
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/getchoo/aur-update
+ arch = any
+ license = MIT
+ provides = aur-update
+ conflicts = aur-update
+ source = https://github.com/getchoo/aur-update/archive/v0.1.0.tar.gz
+ md5sums = 657b502dc511d46adebcfa102cb8c1c6
+
+pkgname = aur-update
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63a06551aa54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Seth Flynn <g3tchoo@protonmail.com>
+
+pkgname=aur-update
+_pkgname=aur-update
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="automatically update PKGBUILD files for the AUR"
+arch=("any")
+url="https://github.com/getchoo/aur-update"
+license=("MIT")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=('https://github.com/getchoo/aur-update/archive/v0.1.0.tar.gz')
+md5sums=('657b502dc511d46adebcfa102cb8c1c6')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX="$pkgdir/usr/local" install
+}