summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2015-10-20 19:38:59 +0200
committerFélix Piédallu2015-10-20 19:38:59 +0200
commitf954bdbe6e8753db97e785034f561375d84ee4a9 (patch)
treefe1c2c9bfaeb47cd7439f7a8d793899f5270c99a
downloadaur-f954bdbe6e8753db97e785034f561375d84ee4a9.tar.gz
first release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72520e3c63e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aur-updater-git
+ pkgdesc = Easy tool to update your PKGBUILDS and update the AUR database automatically
+ pkgver = r2.303470e
+ pkgrel = 1
+ url = https://github.com/Salamandar/aur-updater.git
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = bash
+ depends = pkgbuild-introspection
+ depends = pacman
+ depends = namcap
+ source = git+https://github.com/Salamandar/aur-updater.git
+ sha256sums = SKIP
+
+pkgname = aur-updater-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0f75d817877
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Salamandar <felix@piedallu.me>
+pkgname='aur-updater-git'
+_gitname='aur-updater'
+pkgver=r2.303470e
+pkgrel=1
+pkgdesc="Easy tool to update your PKGBUILDS and update the AUR database automatically"
+arch=('any')
+url="https://github.com/Salamandar/$_gitname.git"
+license=('GPL')
+groups=()
+makedepends=('git')
+depends=('bash' 'pkgbuild-introspection' 'pacman' 'namcap')
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "%s.%s" "$( set -o pipefail
+ git describe --long --tags 2>/dev/null \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g' \
+ | sed -r 's/.([0-9,a-g,A-G]{7}.*)//' ||
+ printf "r%s" "$(git rev-list --count HEAD)"
+ )" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$srcdir/$_gitname"
+ chmod +x ./aur-updater.sh
+
+ install -d $pkgdir/usr/bin/
+ cp ./aur-updater.sh "$pkgdir/usr/bin"
+}