summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzargbell2018-07-31 14:40:21 +0300
committerzargbell2018-07-31 14:40:21 +0300
commitac14bfc5e1a305fa4359323f803d1e9f19f56ece (patch)
tree4d7a966d5f08e503178924ae71a3ca4b6872267f
parent6b1bbeec1917f31a7915ed03b9501e4d6940ed46 (diff)
downloadaur-ac14bfc5e1a305fa4359323f803d1e9f19f56ece.tar.gz
add man page, bash and zsh completions, storing /var/cache
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39bcec307f96..24fd0c9b7ca0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aura-git
pkgdesc = A package manager for Arch Linux and its AUR
- pkgver = 2.0.0.r1459.4f208e8
+ pkgver = 2.0.0.r1465.4c6c481
pkgrel = 1
url = https://github.com/aurapm/aura
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ecc2fe92232e..5298d6545f4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zargbell <zargbell@yandex.ru>
pkgname="aura-git"
-pkgver=2.0.0.r1459.4f208e8
+pkgver=2.0.0.r1465.4c6c481
pkgrel=1
pkgdesc="A package manager for Arch Linux and its AUR"
arch=("x86_64")
@@ -24,10 +24,23 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname}"
- mkdir -p bin
- stack --jobs "$[$(nproc)+1]" --local-bin-path "bin/" install -- aura
+ mkdir -p "aura/bin"
+ stack --jobs "$[$(nproc)+1]" --local-bin-path "aura/bin/" install -- aura
}
package() {
- install -Dm755 "${srcdir}/${pkgname}/bin/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+ cd "${srcdir}/${pkgname}/aura"
+
+ # Install binary
+ install -Dm755 "bin/aura" "${pkgdir}/usr/bin/aura"
+
+ # Install man page
+ install -Dm644 "doc/aura.8" "${pkgdir}/usr/share/man/man8/aura.8"
+
+ # Install bash and zsh completions
+ install -Dm644 "doc/completions/bashcompletion.sh" "${pkgdir}/usr/share/bash-completion/completions/aura"
+ install -Dm644 "doc/completions/_aura" "${pkgdir}/usr/share/zsh/site-functions/_aura"
+
+ # Directory for storing {PKGBUILDs, source packages, installed package states}
+ mkdir -p "${pkgdir}/var/cache/aura"/{pkgbuilds,src,states}
} \ No newline at end of file