summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave Reisner2019-05-29 07:03:25 -0400
committerDave Reisner2019-05-29 07:03:25 -0400
commitd235634675e68a2817656233b55a79209d2fa08d (patch)
tree0abf78ce9a24c5262ad163e81ca71ec2d27c6cde
parentf1049fb648dfd2419a5c1359e1395d2f5a6e6129 (diff)
downloadaur-d235634675e68a2817656233b55a79209d2fa08d.tar.gz
Only pass --wipe to meson if the build dir exists
Getting grumpy...
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa9e7da2ac80..60c75f236d49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = auracle-git
pkgdesc = A flexible client for the AUR
pkgver = r255.5435855
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/falconindy/auracle.git
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 470c8e165dd6..56f7a812464e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=auracle-git
_pkgname=auracle
pkgver=r255.5435855
-pkgrel=1
+pkgrel=2
pkgdesc='A flexible client for the AUR'
arch=('x86_64' 'i686')
url="https://github.com/falconindy/auracle.git"
@@ -23,10 +23,15 @@ pkgver() {
build() {
cd "$_pkgname"
- meson build --wipe \
- --prefix=/usr \
- --buildtype=plain \
+ local meson_args=(
+ --prefix=/usr
+ --buildtype=plain
--default-library=static
+ )
+
+ [[ -d build ]] && meson_args+=(--wipe)
+
+ meson build "${meson_args[@]}"
ninja -C build
}