summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Skelsey2020-05-08 12:50:14 +0200
committerNick Skelsey2020-05-08 12:50:14 +0200
commitf946aa3e1a91f154be7b377dd4ea0a489226ff23 (patch)
tree40208d5014f24405064454f91b2d1fed3de7163c
downloadaur-f946aa3e1a91f154be7b377dd4ea0a489226ff23.tar.gz
Initial pkgbuild
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD24
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..922640f3fdd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = auralcap
+ pkgdesc = Monitor files and make noise
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/NSkelsey/monopticon/tree/master/contrib/expirements/auralcap
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = csound
+ makedepends = corrade
+ makedepends = libevent
+ makedepends = bash
+ makedepends = git
+ depends = csound
+ depends = corrade
+ depends = libevent
+ source = git+https://github.com/nskelsey/monopticon/
+ md5sums = SKIP
+
+pkgname = auralcap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f55bd934444
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Nick Skelsey <nskelsey+zz@gmail.com>
+pkgname=auralcap
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Monitor files and make noise"
+arch=('x86_64')
+url="https://github.com/NSkelsey/monopticon/tree/master/contrib/expirements/auralcap"
+license=('GPL')
+depends=("csound" "corrade" "libevent")
+makedepends=("cmake" "csound" "corrade" "libevent" "bash" "git")
+source=("git+https://github.com/nskelsey/monopticon/")
+md5sums=("SKIP")
+
+build() {
+ cd "$srcdir/monopticon/contrib/expirements/auralcap"
+ mkdir -p "$srcdir/monopticon/contrib/expirements/auralcap/build"
+ cmake -S . -B build
+ cmake --build build
+}
+
+package() {
+ cd "$srcdir/monopticon/contrib/expirements/auralcap/build"
+ make DESTDIR="$pkgdir/" install
+}