summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2018-10-04 20:48:43 +0200
committerStephan Springer2018-10-04 20:48:43 +0200
commit4e18ab7ff76ed4ba0507790ba62a93af751afbba (patch)
tree6d814183377de335e6923326605b7d4b81369cad
downloadaur-4e18ab7ff76ed4ba0507790ba62a93af751afbba.tar.gz
version 0.5.2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e64b1ca8bcc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = aurblobs
+ pkgdesc = Automatically create binary repositories from AUR packages
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/aurblobs/aurblobs
+ arch = any
+ license = AGPL3
+ makedepends = python-setuptools
+ depends = python-click
+ depends = python-docker
+ depends = python-gitpython
+ depends = git
+ depends = python-pretty_bad_protocol
+ depends = python-xdg
+ source = aurblobs-0.5.2.tar.gz::https://github.com/aurblobs/aurblobs/archive/v0.5.2.tar.gz
+ sha256sums = 956c429ec30e5606fbd94b8b057129c2b6b6b28bd2a722822a61c683c25bcf12
+
+pkgname = aurblobs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d702763b46cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+
+pkgname=aurblobs
+pkgver=0.5.2
+pkgrel=1
+pkgdesc='Automatically create binary repositories from AUR packages'
+arch=('any')
+url='https://github.com/aurblobs/aurblobs'
+license=('AGPL3')
+makedepends=('python-setuptools')
+depends=('python-click' 'python-docker' 'python-gitpython' 'git'
+ 'python-pretty_bad_protocol' 'python-xdg')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('956c429ec30e5606fbd94b8b057129c2b6b6b28bd2a722822a61c683c25bcf12')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}