summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2018-09-10 18:48:40 +0200
committerStephan Springer2018-09-10 18:48:40 +0200
commit30eb83afa579d691e735b311bef8e5325079a1c8 (patch)
treec4ab5fd3b6f9d802d3282cb9df9369eb63e8a57f
parent7b072669ead52ee57b175286387a1f366d93ee96 (diff)
downloadaur-30eb83afa579d691e735b311bef8e5325079a1c8.tar.gz
improve pkgdesc
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae54cffedc93..13f5bab9fefd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = aurblobs-git
- pkgdesc = Automatically build AUR packages and serve them from a repository (git version)
+ pkgdesc = Automatically create binary repositories from AUR packages
pkgver = r80.2dfcc20
pkgrel = 1
url = https://github.com/aurblobs/aurblobs
arch = any
license = AGPL3
- makedepends = git
makedepends = python-setuptools
depends = python-click
depends = python-docker
diff --git a/PKGBUILD b/PKGBUILD
index 5378bedd62c4..745fa98ab8c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,26 @@ _pkgname=aurblobs
pkgname="$_pkgname-git"
pkgver=r80.2dfcc20
pkgrel=1
-pkgdesc='Automatically build AUR packages and serve them from a repository (git version)'
+pkgdesc='Automatically create binary repositories from AUR packages'
arch=('any')
url='https://github.com/aurblobs/aurblobs'
license=('AGPL3')
-makedepends=('git' 'python-setuptools')
+makedepends=('python-setuptools')
depends=('python-click' 'python-docker' 'python-gitpython' 'git'
'python-pretty_bad_protocol' 'python-xdg')
source=("git+https://github.com/$_pkgname/$_pkgname.git"
- 'fix-constants.diff')
+ 'fix-constants.diff')
sha256sums=('SKIP' 'SKIP')
pkgver() {
- cd "$_pkgname/"
+ cd "$_pkgname"
printf "r%s.%s" \
"$(git rev-list --count HEAD)" \
"$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$_pkgname/"
+ cd "$_pkgname"
patch -p2 -i "$srcdir"/fix-constants.diff
}