summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Heidler2015-06-08 11:04:20 +0200
committerDominik Heidler2015-06-08 11:04:20 +0200
commit853df1bdd9299ee10d00b74913d9382664803448 (patch)
tree3b10d28f92ae6a7904fda0d0e16dd72e03b81f99
downloadaur-853df1bdd9299ee10d00b74913d9382664803448.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD30
-rw-r--r--aurbs.install19
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cdba860bf9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = aurbs
+ pkgdesc = AUR package build system
+ pkgver = 1.3.1
+ pkgrel = 3
+ url = http://github.com/asdil12/aurbs
+ install = aurbs.install
+ arch = any
+ license = GPL
+ depends = devtools
+ depends = rsync
+ depends = python
+ depends = python-setuptools
+ depends = python-simplejson
+ depends = python-yaml
+ depends = python-pymongo
+ depends = python-flask
+ depends = pyalpm
+ depends = python-flup-hg
+ backup = etc/aurbs.yml
+ backup = var/lib/aurbs/aurstaging/i686/aurstaging.db.tar.gz
+ backup = var/lib/aurbs/aurstaging/x86_64/aurstaging.db.tar.gz
+ source = aurbs-1.3.1.tar.gz::https://codeload.github.com/asdil12/aurbs/tar.gz/1.3.1
+ md5sums = 983e1b6b61fb4b0b52075d96cf27399b
+
+pkgname = aurbs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b34f85577b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dominik Heidler <dheidler@gmail.com>
+
+pkgname=aurbs
+pkgver=1.3.1
+pkgrel=3
+pkgdesc="AUR package build system"
+arch=('any')
+url="http://github.com/asdil12/aurbs"
+license=('GPL')
+groups=()
+provides=()
+install="aurbs.install"
+depends=(
+ 'devtools' 'rsync' 'python'
+ 'python-setuptools' 'python-simplejson' 'python-yaml' 'python-pymongo' 'python-flask' 'pyalpm'
+ 'python-flup-hg'
+)
+backup=(
+ 'etc/aurbs.yml'
+ 'var/lib/aurbs/aurstaging/i686/aurstaging.db.tar.gz'
+ 'var/lib/aurbs/aurstaging/x86_64/aurstaging.db.tar.gz'
+)
+
+source=("$pkgname-$pkgver.tar.gz::https://codeload.github.com/asdil12/$pkgname/tar.gz/$pkgver")
+md5sums=('983e1b6b61fb4b0b52075d96cf27399b')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make install DESTDIR=$pkgdir
+}
diff --git a/aurbs.install b/aurbs.install
new file mode 100644
index 000000000000..d2ce2450e542
--- /dev/null
+++ b/aurbs.install
@@ -0,0 +1,19 @@
+post_install() {
+ post_upgrade $1
+ echo ">>> Find a sample lighttp config at:"
+ echo ">>> /usr/share/doc/aurbs/lighttpd.conf.sample"
+}
+
+post_upgrade() {
+ if ! getent passwd aurbs >/dev/null; then
+ useradd --system -c 'aurbs daemon user' -g daemon -d /var/cache/aurbs -s /bin/bash aurbs
+ fi
+ chown -R aurbs: /var/cache/aurbs/ccache/*
+ chown -R aurbs: /var/cache/aurbs/build/*/*
+}
+
+post_remove() {
+ if getent passwd aurbs >/dev/null; then
+ userdel aurbs
+ fi
+}