summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Mettke2018-02-09 19:02:34 +0100
committerMarc Mettke2018-02-09 19:02:34 +0100
commitaef4649de0fbd7e2aa9541ca4d8546f922888aa0 (patch)
treef70a5d9bbb9449dc28b7de36bf86b0ec326c4f09
downloadaur-aef4649de0fbd7e2aa9541ca4d8546f922888aa0.tar.gz
[aurebuildcheck-rs-git] Initial Version of aurebuildcheck-rs-git
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0335d2319df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = aurebuildcheck-rs-git
+ pkgdesc = Archlinux package checker to identify packages which may need a rebuild
+ pkgver = 0.2.0.r0.gec90d62
+ pkgrel = 1
+ url = https://github.com/mettke/aurebuildcheck-rs
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = rust
+ depends = gcc-libs
+ depends = pacman
+ depends = which
+ depends = file
+ optdepends = glibc: perform checks via ldd
+ optdepends = binutils: perform checks via readelf
+ optdepends = pkgfile: find packages containing missing libraries
+ provides = aurebuildcheck-rs
+ conflicts = aurebuildcheck-rs
+ source = aurebuildcheck-rs::git+https://github.com/mettke/aurebuildcheck-rs.git
+ md5sums = SKIP
+
+pkgname = aurebuildcheck-rs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7244e0a337d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Marc Mettke <marc@itmettke.de>
+_pkgname=aurebuildcheck-rs
+pkgname=$_pkgname-git
+pkgver=1
+pkgrel=1
+pkgdesc="Archlinux package checker to identify packages which may need a rebuild"
+arch=('x86_64')
+url="https://github.com/mettke/aurebuildcheck-rs"
+license=('MIT')
+depends=('gcc-libs' 'pacman' 'which' 'file')
+makedepends=('git' 'rust')
+optdepends=(
+ 'glibc: perform checks via ldd'
+ 'binutils: perform checks via readelf'
+ 'pkgfile: find packages containing missing libraries'
+)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./build_release.sh
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 LICENSE "$pkgdir/usr/share/licenses/aurebuildcheck-rs-git/LICENSE"
+ install -Dm755 target/release/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+}