summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinz20082022-04-07 15:18:51 +0200
committerVinz20082022-04-07 15:18:51 +0200
commit3b6c151396dff2a09646d9ada7a11e4bc1225947 (patch)
tree3264248930f9689d5fdeda1eed04b73276d6b15f
downloadaur-3b6c151396dff2a09646d9ada7a11e4bc1225947.tar.gz
first commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b4878300c63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = aurh-git
+ pkgdesc = An AUR Helper
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/Vinz2008/Aurh
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = curl
+ source = aurh::git+https://github.com/vinz2008/Aurh.git
+ sha256sums = SKIP
+
+pkgname = aurh-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c2cb357fd360
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+aurh
+src
+aurh-git-* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e988ef0adcd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Vincent Bidard de la Noƫ vincentbidarddelanoe@gmail.com
+pkgname="aurh-git"
+pkgver="0.2"
+pkgrel=1
+pkgdesc="An AUR Helper"
+arch=('any')
+url="https://github.com/Vinz2008/Aurh"
+license=('GPL')
+makedepends=("git")
+depends=("curl")
+sha256sums=('SKIP')
+install=
+changelog=
+source=("aurh::git+https://github.com/vinz2008/Aurh.git")
+noextract=()
+
+
+build() {
+ echo ${srcdir}
+ cd ${srcdir}/aurh
+ make
+}
+
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/aurh/aurh" "${pkgdir}/usr/bin/aurh"
+ chmod a+x "${pkgdir}/usr/bin/aurh"
+}