summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoolfool2022-03-14 18:17:42 +0530
committercoolfool2022-03-14 18:17:42 +0530
commitc1d7e086f9c2a87c0e7dfec9acfbab66162be5c1 (patch)
treef9039912c46686191377aee8d0cccad37b58463c
parentca9115d66387c62fef43dff4dbc4de9fee1848c3 (diff)
downloadaur-c1d7e086f9c2a87c0e7dfec9acfbab66162be5c1.tar.gz
Updated pkgbuild to aur guidelines
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f7ed7e81c9c..5661b212e9d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aurishem
pkgdesc = Safe and Easy way to build and install packages directly from Arch User Repository
- pkgver = 1.0.0
+ pkgver = 1.0.0.r0.g482b61c
pkgrel = 1
url = https://github.com/coolfool/aurishem
arch = any
@@ -8,7 +8,9 @@ pkgbase = aurishem
makedepends = git
depends = python-pydbus
depends = python-gobject
- source = git://github.com/coolfool/aurishem
+ provides = aurishem
+ conflicts = aurishem
+ source = git+https://github.com/coolfool/aurishem.git
sha1sums = SKIP
pkgname = aurishem
diff --git a/PKGBUILD b/PKGBUILD
index f49ec8412b34..b4ab36967745 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: CoolFool <coolfool149@gmail.com>
pkgname=aurishem
-pkgver=1.0.0
+pkgver=1.0.0.r0.g482b61c
pkgrel=1
pkgdesc="Safe and Easy way to build and install packages directly from Arch User Repository"
arch=("any")
@@ -8,13 +8,20 @@ url="https://github.com/coolfool/aurishem"
license=('MIT')
depends=('python-pydbus' 'python-gobject')
makedepends=('git')
-source=("git://github.com/coolfool/${pkgname}")
+conflicts=('aurishem')
+provides=('aurishem')
+source=("git+https://github.com/coolfool/aurishem.git")
sha1sums=('SKIP')
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
package() {
install -D "$srcdir/aurishem/source/aurishem.desktop" "$pkgdir/usr/share/applications/aurishem.desktop"
install -D "$srcdir/aurishem/source/aurishem.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/aurishem.png"
install -D "$srcdir/aurishem/source/aurishem" "$pkgdir/usr/bin/aurishem"
chmod +x "$pkgdir/usr/bin/aurishem"
xdg-mime default aurishem.desktop x-scheme-handler/aurishem
-} \ No newline at end of file
+}