summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHunter Brodie2021-11-08 16:30:17 -0500
committerHunter Brodie2021-11-08 16:30:17 -0500
commitefc6354b64a4517fe915b40b5e446fd124449ada (patch)
tree10320556128af92a0bb011472cc9b1e67cf28470
parentfe27972fbe4799b5e8497bf1c9062e0927befd12 (diff)
downloadaur-efc6354b64a4517fe915b40b5e446fd124449ada.tar.gz
Rewrote so it is much cleaner and should actually work consistently now
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD35
2 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b55726bc02d6..2bb804ca110c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = aurora-git
- pkgdesc = Yet another wrapper for pacman to access the AUR written in Rust.
- pkgver = r2.1711939
+ pkgdesc = A minimal AUR helper written in Rust
+ pkgver = r5.a90eeb3
pkgrel = 1
url = https://gitlab.com/hunterbrodie/aurora
arch = x86_64
license = GPL
makedepends = cargo
- depends = opendoas
- depends = git
- depends = pkgfile
+ depends = pacman
source = aurora-git::git+https://gitlab.com/hunterbrodie/aurora.git
md5sums = SKIP
pkgname = aurora-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c82828e6b468..177b5b5a5c13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,50 @@
# Maintainer: Hunter Brodie <hunterbrodie@gmail.com>
pkgname='aurora-git'
-pkgver=r2.1711939
+pkgver=r5.a90eeb3
pkgrel=1
-pkgdesc="Yet another wrapper for pacman to access the AUR written in Rust."
+pkgdesc="A minimal AUR helper written in Rust"
arch=('x86_64')
url="https://gitlab.com/hunterbrodie/aurora"
license=('GPL')
-depends=('opendoas' 'git' 'pkgfile')
+depends=('pacman')
makedepends=('cargo')
-source=('aurora-git::git+https://gitlab.com/hunterbrodie/aurora.git')
+source=("$pkgname::git+https://gitlab.com/hunterbrodie/aurora.git")
md5sums=('SKIP')
pkgver()
{
- cd "$srcdir/${pkgname%-VCS}"
-
+ cd "$pkgname"
+
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare()
+{
+ cd "$pkgname"
+
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
build()
{
cd "$pkgname"
- cargo build --release --locked --all-features --target-dir=target
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check()
+{
+ cd "$pkgname"
+
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
}
package()
{
cd "$pkgname"
- install -Dm 755 target/release/aurora -t "${pkgdir}/usr/bin"
+
+ install -Dm0755 -t "$pkgdir/usr/bin" "target/release/aurora"
}