summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-03-23 16:45:19 +0100
committerXZS2016-03-23 17:55:35 +0100
commit2ec926d3b769212708745e3b1c8eb1402706a27a (patch)
treeefde3a77906862d0736aad77ff4cb2224dc9caa2
parent331e02e85cda494a103e652bd0e95279f6538bcf (diff)
downloadaur-2ec926d3b769212708745e3b1c8eb1402706a27a.tar.gz
move source to GNOME-Look.org
Instead of involving Dropbox, the source archive can now be retrieved directly from GNOME-Look.org. Packaging and version routine are adapted to the directory name that does no longer include the gnome-shell version the theme applies to.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca4494152d9a..2f88ed4794b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = aurora-themes
pkgdesc = Easy On The Eyes GNOME Shell, GTK2, GTK3 and Cinnamon themes
- pkgver = 3.18.20160229
+ pkgver = 3.18.20160321
pkgrel = 1
url = http://opendesktop.org/content/show.php?content=170523
arch = any
license = GPL3
optdepends = gtk-engine-murrine: for GTK2 themes
- source = aurora-themes.tar.gz::https://www.dropbox.com/s/4ik0pbbpsiqe4ci/Aurora-3.18.tar.gz?dl=1
- sha256sums = eecedbcc5e9b56a296b2effc45c790df6ab7ef447cb17a6f0c04cccbac589075
+ source = http://gnome-look.org/CONTENT/content-files/170523-Dark-Aurora.tar.gz
+ sha256sums = 506332ec0d86b90f0e41be79875fa7b40bb923caf01c1412cf02020a6d056f28
pkgname = aurora-themes
diff --git a/PKGBUILD b/PKGBUILD
index 9baefddd07e6..27fc2f035ce2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,29 @@
# Contributor: FadeMind <fademind@gmail.com>
pkgname=aurora-themes
-pkgver=3.18.20160229
+pkgver=3.18.20160321
pkgrel=1
pkgdesc="Easy On The Eyes GNOME Shell, GTK2, GTK3 and Cinnamon themes"
arch=('any')
url="http://opendesktop.org/content/show.php?content=170523"
license=('GPL3')
optdepends=("gtk-engine-murrine: for GTK2 themes")
-source=("${pkgname}.tar.gz::https://www.dropbox.com/s/4ik0pbbpsiqe4ci/Aurora-${pkgver%.*}.tar.gz?dl=1")
-sha256sums=('eecedbcc5e9b56a296b2effc45c790df6ab7ef447cb17a6f0c04cccbac589075')
+source=("http://gnome-look.org/CONTENT/content-files/${url##*=}-Dark-Aurora.tar.gz")
+sha256sums=('506332ec0d86b90f0e41be79875fa7b40bb923caf01c1412cf02020a6d056f28')
pkgver() {
- dir="$(echo Aurora-*)"
- echo -n "${dir##*-}."
+ echo -n "3.18."
while read -rd $'\0'
do
if [[ "$REPLY" -gt "$max" ]]
then
max="$REPLY"
fi
- done < <(find "$dir" -type f -exec stat --printf="%Y\0" '{}' +)
+ done < <(find */ -type f -exec stat --printf="%Y\0" '{}' +)
date -d "@$max" +%Y%m%d
}
package() {
install -d ${pkgdir}/usr/share/themes
- cp --no-preserve=mode -r ${srcdir}/Aurora-3.18/* ${pkgdir}/usr/share/themes
+ cp --no-preserve=mode -r ${srcdir}/*/ ${pkgdir}/usr/share/themes
}