summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-03-23 17:43:41 +0100
committerXZS2016-03-23 17:57:19 +0100
commit52d48bf42f5becb9c9811ed264b65f318823e7ac (patch)
tree6a00ff9b3daa0bd07f7514fa1b3733ee1e7ed75b
parentab57e428868863e971047aa0ac3dcb801ed64135 (diff)
downloadaur-52d48bf42f5becb9c9811ed264b65f318823e7ac.tar.gz
utilize version in dependency
Now that the package version can also be readily aware of the compatible gnome-shell version, the information can be exposed to the user, warning of possible incompatibilities when updating gnome-shell.
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 601199fa3da3..9be9968b7dd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,6 +42,12 @@ pkgver() {
}
package() {
+ extend-optdepends
install -d ${pkgdir}/usr/share/themes
cp --no-preserve=mode -r ${srcdir}/*/ ${pkgdir}/usr/share/themes
}
+
+# Hidden in a subfunction not to show up in the .SRCINFO.
+extend-optdepends() {
+ optdepends+=("gnome-shell=$(cat version): for gnome-shell themes")
+}