summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-11-04 00:50:31 +0100
committerXZS2016-11-04 14:55:13 +0100
commit59c54a84772f512ef7cb340172a318cc61aaa02c (patch)
tree478abcbf8eb6354cbdb0e11185cbb45fb7df8d26
parentaaf11e5e119666ad7ffcf6f1989f2ffc50533eca (diff)
downloadaur-59c54a84772f512ef7cb340172a318cc61aaa02c.tar.gz
rename version file
As the protocol already tells, it contains more meta-data than just version information and should thus be named accordingly.
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 610452a2cd9e..45730ed697d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ url='https://www.opendesktop.org/p/1143475'
license=('GPL3')
makedepends=('jq')
optdepends=('gtk-engine-murrine: for GTK2 themes')
-source=("version::meta://dl.opendesktop.org/api/files/index?format=json&status=active&collection_content_id=${url##*/}"
+source=("meta::meta://dl.opendesktop.org/api/files/index?format=json&status=active&collection_content_id=${url##*/}"
'https://dl.opendesktop.org/api/files/download/id/1468995652/Dark-Aurora.tar.gz')
sha256sums=('0f20c0287933ea77e0830d856ff75d6e99c80cf3ba185bda5fd6a662bae049b4'
'6fbdaaae2e59b5f514ca003ba2552fcb7eb5724bd278e291ed5ae2036563d6ff')
@@ -28,7 +28,7 @@ DLAGENTS=("meta::/usr/bin/bash -c $(
"${DLAGENTS[@]}")
pkgver() {
- js -j '.version' version
+ js -j '.version' meta
while read -rd $'\0'
do
if [[ "$REPLY" -gt "$max" ]]
@@ -47,5 +47,5 @@ package() {
# Hidden in a subfunction not to show up in the .SRCINFO.
extend-optdepends() {
- optdepends+=("gnome-shell=$(jq -j .version version): for gnome-shell themes")
+ optdepends+=("gnome-shell=$(jq -j .version meta): for gnome-shell themes")
}