summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2015-12-25 14:21:44 +0100
committerXZS2015-12-25 14:23:58 +0100
commitf48b7009256988eba38c36b13524d2eeeff9c4ae (patch)
treee6988264427219a01c6c68b923e313eb04a2b144
parent1866bb67265fe0c09ad5a3e9d4994a69281743a0 (diff)
downloadaur-f48b7009256988eba38c36b13524d2eeeff9c4ae.tar.gz
condense installation process
Instead of fixing the file modes after placing them, a cp switch is available to do both in one go.
-rw-r--r--PKGBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ba8707f8834..6c3f61204ba7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,5 @@ sha256sums=('bae3d9c16ed37ad9e3a67a4d019d2e8bff70a7fadbf87a722c2a960d6fd56a4c')
package() {
install -d ${pkgdir}/usr/share/themes
- cp -rf ${srcdir}/Aurora-3.18/* ${pkgdir}/usr/share/themes
- find ${pkgdir}/usr -type f -exec chmod 644 {} \;
- find ${pkgdir}/usr -type d -exec chmod 755 {} \;
+ cp --no-preserve=mode -r ${srcdir}/Aurora-3.18/* ${pkgdir}/usr/share/themes
}