summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBennett Piater2017-03-10 10:57:28 +0100
committerBennett Piater2017-03-10 10:57:28 +0100
commitbcc012967c7c26007cef26ea433472a0261c775c (patch)
tree3cc483b47fe3608cd40104146c7e2c99505f9499
parent1260b418da71da5ce157078a84b2efbab4b17c6a (diff)
downloadaur-bcc012967c7c26007cef26ea433472a0261c775c.tar.gz
upgpkg: aursec-git v0.9.r35.08f6f6a-1
upstream release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 34 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2e807fd6070..92d472ddb3d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,8 @@
-# Generated by mksrcinfo v8
-# Fri Dec 2 15:17:39 UTC 2016
pkgbase = aursec-git
pkgdesc = Verify AUR package sources against hashes stored in a blockchain.
- pkgver = v0.0.6b.r3.bff1e32
- pkgrel = 2
- url = https://github.com/clawoflight/aursec
- install = aursec-git.install
+ pkgver = v0.9.r35.08f6f6a
+ pkgrel = 1
+ url = https://github.com/clawoflight/
arch = any
license = custom:MPL2
checkdepends = shellcheck
@@ -18,7 +15,18 @@ pkgbase = aursec-git
provides = aursec
conflicts = aursec
source = git+https://github.com/clawoflight/aursec.git
+ validpgpkeys = 871F10477DB3DDED5FC447B226C7E577EF967808
sha256sums = SKIP
pkgname = aursec-git
+ install = aursec-git.install
+ optdepends = aursec-tui: to manually inspect the blockchain.
+
+pkgname = aursec-tui-git
+ pkgdesc = Inspect the aursec blockchain
+ depends = python
+ depends = python-urwid
+ depends = aursec
+ provides = aursec-tui
+ conflicts = aursec-tui
diff --git a/PKGBUILD b/PKGBUILD
index e20063ef3136..91c40e4e22f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Bennett Piater <bennett at piater dot name>
-pkgname=aursec-git
-pkgver=v0.0.6b.r3.bff1e32
-pkgrel=2
+pkgname=(aursec-git aursec-tui-git)
+pkgver=v0.9.r35.08f6f6a
+pkgrel=1
pkgdesc='Verify AUR package sources against hashes stored in a blockchain.'
arch=(any)
-url="https://github.com/clawoflight/${pkgname%-git}"
+url="https://github.com/clawoflight/${pkgbase%-git}"
license=('custom:MPL2')
provides=("${pkgname%-git}")
@@ -20,7 +20,6 @@ checkdepends=(shellcheck)
source=("git+https://github.com/clawoflight/${pkgname%-git}.git")
sha256sums=('SKIP')
validpgpkeys=('871F10477DB3DDED5FC447B226C7E577EF967808')
-install=aursec-git.install
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -30,6 +29,8 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}/aursec"
make
+ cd "$srcdir/${pkgname%-git}/tui"
+ make
}
check() {
@@ -37,7 +38,20 @@ check() {
make -k check
}
-package() {
+package_aursec-git() {
+ install=aursec-git.install
+ optdepends=("aursec-tui: to manually inspect the blockchain.")
+
cd "$srcdir/${pkgname%-git}/aursec"
make PREFIX="/usr" DESTDIR="$pkgdir/" install
}
+
+package_aursec-tui-git() {
+ pkgdesc='Inspect the aursec blockchain'
+ depends=(python python-urwid aursec)
+ provides=(aursec-tui)
+ conflicts=(aursec-tui)
+
+ cd "$srcdir/aursec/tui"
+ make PREFIX="/usr" DESTDIR="$pkgdir/" install
+}