summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuck Boles2022-09-20 13:26:49 -0500
committerHuck Boles2022-09-20 13:26:49 -0500
commitb27588ce466f03521b9c44c033a59373b1d19b6e (patch)
tree2074097470fc8b9ea583e64e7f6151b7ec75d5b1
parentb9ea976d08e06933acccdb28e98474ede973fe2e (diff)
downloadaur-b27588ce466f03521b9c44c033a59373b1d19b6e.tar.gz
v0.2 refactoring and pacman integration
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD2
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 043a66ab9eff..5a8d0f72eaae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,11 +4,10 @@ pkgbase = aursh
pkgrel = 1
url = https://github.com/huboles/aursh
install = aursh.install
- arch = x86_64
+ arch = any
groups = aursh
license = GPL
- depends = git
- depends = curl
+ depends = bash
source = aursh-0.2.tar.gz::https://github.com/huboles/aursh/releases/download/testing/aursh-0.2.tar.gz
sha256sums = f671611ba69d9e60dd729589b67a2342909a34af0abb64b42ce9f72801cbcf97
diff --git a/PKGBUILD b/PKGBUILD
index 7728640ba3bd..43827aee9d9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,10 @@ arch=('any')
url="https://github.com/huboles/aursh"
license=('GPL')
groups=('aursh')
+depends=('bash')
source=("$pkgname-$pkgver.tar.gz::$url/releases/download/testing/$pkgname-$pkgver.tar.gz")
install=aursh.install
+BUILDENV+=('!check')
package() {
cd "$srcdir" || exit
install -Dm644 aursh.conf "$pkgdir/etc/$pkgname/aursh.conf"