summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:22:47 +0200
committerAlexander F Rødseth2015-06-10 15:22:47 +0200
commit0e2217702a1873420439872e3c9dd1f20be64137 (patch)
tree42a65cc21a211ccfcbd6337de692b8dcf17f1357
downloadaur-0e2217702a1873420439872e3c9dd1f20be64137.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e62b8cfa199
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aurtic
+ pkgdesc = Download and extract source packages from AUR
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/xyproto/aurtic/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = git://github.com/xyproto/aurtic#tag=0.2
+ md5sums = SKIP
+
+pkgname = aurtic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a3de3f9af6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alexander Rødseth <xyproto@archlinux.org>
+
+pkgname=aurtic
+pkgver=0.2
+pkgrel=1
+pkgdesc='Download and extract source packages from AUR'
+arch=('x86_64' 'i686')
+url='https://github.com/xyproto/aurtic/'
+license=('MIT')
+makedepends=('go' 'git')
+source=("git://github.com/xyproto/aurtic#tag=$pkgver")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+
+ GOPATH="$srcdir" go get -d
+}
+
+build() {
+ cd "$pkgname"
+
+ GOPATH="$srcdir" go build
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: