summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Butler2018-02-03 13:59:38 +0000
committerAlex Butler2018-02-03 13:59:38 +0000
commit04f52515ffadee88e80efd7d687e33938fb64249 (patch)
tree3846b3f49b15ade757906509055b76bb15e383e6
parent623e7eac7b768d908c7543eff39edbd82e9c4030 (diff)
downloadaur-04f52515ffadee88e80efd7d687e33938fb64249.tar.gz
0.3.1-1: Clarify install script
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--aurto.install7
3 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87ba70cc6335..8fdf7dcbf4d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aurto
pkgdesc = A simple aur tool for managing a local 'aurto' repository
- pkgver = 0.3
- pkgrel = 2
+ pkgver = 0.3.1
+ pkgrel = 1
url = https://github.com/alexheretic/aurto
install = aurto.install
arch = any
@@ -10,8 +10,8 @@ pkgbase = aurto
depends = devtools
depends = systemd
depends = pacutils
- source = https://github.com/alexheretic/aurto/archive/v0.3.tar.gz
- sha256sums = ae01bc2813bcec19e5685bc1261b3847a3e7c3ac8c9fcfbdb57a933d23a79a64
+ source = https://github.com/alexheretic/aurto/archive/v0.3.1.tar.gz
+ sha256sums = e07f42e6a213dae27718182b66461efd0cf9a3f18eb1f384745be89f6eb6f314
pkgname = aurto
diff --git a/PKGBUILD b/PKGBUILD
index ac25a7f62262..0e9a6b17b030 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Butler <alexheretic@gmail.com>
pkgname=aurto
-pkgver=0.3
-pkgrel=2
+pkgver=0.3.1
+pkgrel=1
pkgdesc="A simple aur tool for managing a local 'aurto' repository"
arch=('any')
url="https://github.com/alexheretic/aurto"
@@ -14,7 +14,7 @@ optdepends=()
makedepends=()
install="aurto.install"
source=("https://github.com/alexheretic/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('ae01bc2813bcec19e5685bc1261b3847a3e7c3ac8c9fcfbdb57a933d23a79a64')
+sha256sums=('e07f42e6a213dae27718182b66461efd0cf9a3f18eb1f384745be89f6eb6f314')
build() {
cd "$pkgname-$pkgver"
diff --git a/aurto.install b/aurto.install
index 721856f1613c..883f594f2647 100644
--- a/aurto.install
+++ b/aurto.install
@@ -17,6 +17,7 @@ function setup_sudoers {
}
function clean_sudoers {
+ ## removes everything between `## aurto rules` & `## /aurto rules` in the sudoers file
sed -i '/^## aurto rules$/,/^## \/aurto rules$/d' /etc/sudoers
}
@@ -33,19 +34,19 @@ post_install() {
install -d /var/cache/pacman/aurto -o "$user"
sudo -u "$user" repo-add /var/cache/pacman/aurto/aurto.db.tar 2>/dev/null
- echo 'aurto: Adding include /etc/pacman.d/aurto to pacman.conf' >&2
+ echo 'aurto: Adding include /etc/pacman.d/aurto >> pacman.conf' >&2
if ! test -f /etc/pacman.conf.aurto-backup; then
cp /etc/pacman.conf /etc/pacman.conf.aurto-backup
fi
echo -e "# aurto repo\\nInclude = /etc/pacman.d/aurto" >> /etc/pacman.conf
- echo 'aurto: Adding passwordless use of arch-nspawn, mkarchroot, makechrootpkg, aurbuild_chroot' >&2
+ echo 'aurto: Adding passwordless use of arch-nspawn, makechrootpkg, aurbuild_chroot, pacsync aurto' >&2
if ! test -f /etc/sudoers.aurto-backup; then
cp /etc/sudoers /etc/sudoers.aurto-backup
fi
setup_sudoers
- echo 'aurto: Adding systemd timer update tasks' >&2
+ echo 'aurto: Adding & enabling systemd timer update tasks' >&2
systemctl enable --now /usr/lib/systemd/system/check-aurto-git-trigger.timer
systemctl enable --now /usr/lib/systemd/system/update-aurto.timer
}