summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Brunelli2015-06-10 22:38:34 -0300
committerIan Brunelli2015-06-10 22:38:34 -0300
commitec935e93e8ec0a278e24f53fa355fcc51759ff5a (patch)
tree8abc8a48c27d120cd687292d2bfa6fee73943450
downloadaur-ec935e93e8ec0a278e24f53fa355fcc51759ff5a.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1c5ddd1faff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = aurupbot
+ pkgdesc = A script to automatically maintain your VCS-based AUR packages for you
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/ianbrunelli/aurupbot
+ arch = any
+ license = GPL2
+ depends = curl
+ depends = git
+ depends = namcap
+ depends = pkgbuild-introspection
+ optdepends = libnotify: send desktop notifications
+ optdepends = s-nail: send reports using the mail command
+ source = https://github.com/ianbrunelli/aurupbot/archive/v1.0.tar.gz
+ sha256sums = b152c2bd9b23fe805ca9a6b08998ea8332379cb94fdb5e6530d397058073e7a4
+
+pkgname = aurupbot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89bb54096c31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Ian Brunelli <ian@brunelli.me>
+
+pkgname=aurupbot
+pkgver=1.0
+pkgrel=1
+pkgdesc="A script to automatically maintain your VCS-based AUR packages for you"
+arch=(any)
+license=(GPL2)
+url=https://github.com/ianbrunelli/aurupbot
+depends=(curl git namcap pkgbuild-introspection)
+optdepends=("libnotify: send desktop notifications"
+ "s-nail: send reports using the mail command")
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=(b152c2bd9b23fe805ca9a6b08998ea8332379cb94fdb5e6530d397058073e7a4)
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install "$srcdir/$pkgname-$pkgver/aurupbot" "$pkgdir/usr/bin/aurupbot" -m 755 || return 1
+ mkdir -p "$pkgdir/etc"
+ install "$srcdir/$pkgname-$pkgver/aurupbotrc" "$pkgdir/etc/$aurupbotrc" -m 644 || return 1
+}