summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2023-03-23 17:35:15 +0100
committerAlad Wenter2023-03-23 17:35:15 +0100
commit010e25d61309c32be80956e8f76af1297be3b382 (patch)
treeb7b87433d801a970ec2ce930565057a2e7d127a3
parent528115a72c3542f0e6aac8336640708ce6007b8e (diff)
downloadaur-010e25d61309c32be80956e8f76af1297be3b382.tar.gz
aurutils: 13
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--aurutils.changelog58
3 files changed, 62 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a4a46dfdf64..24a93cd6c78d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aurutils
pkgdesc = helper tools for the arch user repository
- pkgver = 12.1
+ pkgver = 13
pkgrel = 1
url = https://github.com/AladW/aurutils
install = aurutils.install
@@ -21,7 +21,7 @@ pkgbase = aurutils
optdepends = bat: view-delta example script
optdepends = git-delta: view-delta example script
optdepends = setconf: sync-rebuild example script
- source = aurutils-12.1.tar.gz::https://github.com/AladW/aurutils/archive/refs/tags/12.1.tar.gz
- sha256sums = ed5374ef8e98bda345d44b8d93fb30a96608a050e5ec30c57697a744c3c9ad6a
+ source = aurutils-13.tar.gz::https://github.com/AladW/aurutils/archive/refs/tags/13.tar.gz
+ sha256sums = 5f1151e249b763d4baf3926cea1eb87aa89b737f457b8daf5be25e5ffa7296de
pkgname = aurutils
diff --git a/PKGBUILD b/PKGBUILD
index afd934259a9f..a6839faa7a25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alad Wenter <https://github.com/AladW>
# Co-Maintainer: Cedric Girard <cgirard [dot] archlinux [at] valinor [dot] fr>
pkgname=aurutils
-pkgver=12.1
+pkgver=13
pkgrel=1
pkgdesc='helper tools for the arch user repository'
url='https://github.com/AladW/aurutils'
@@ -10,7 +10,7 @@ license=('custom:ISC')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
changelog=aurutils.changelog
install=aurutils.install
-sha256sums=('ed5374ef8e98bda345d44b8d93fb30a96608a050e5ec30c57697a744c3c9ad6a')
+sha256sums=('5f1151e249b763d4baf3926cea1eb87aa89b737f457b8daf5be25e5ffa7296de')
depends=('git' 'jq' 'pacutils' 'curl' 'perl')
optdepends=('bash-completion: bash completion'
'zsh: zsh completion'
diff --git a/aurutils.changelog b/aurutils.changelog
index ab5bce4e2b14..093b323f412d 100644
--- a/aurutils.changelog
+++ b/aurutils.changelog
@@ -1,8 +1,64 @@
+## 13
+
+* `aur-build`
+ + add `--null` (`-z`)
+ + add `AUR_BUILD_PKGLIST` environment variable
+
+* `aur-build--pkglist`
+ + remove `--user` (`-U`)
+ + only run as root with `AUR_ASROOT` set
+
+* `aur-depends`
+ + add `--assume-installed`
+
+* `aur-srcver`
+ + accept arbitrary source directories as arguments
+ + add `--arg-file` (`-a`), `--null` (`-z`), `--margs`
+ + add `AUR_MAKEPKG` environment variable
+ + only run as root with `AUR_ASROOT` set
+ + exit 1 if any `makepkg` job failed
+
+* `aur-sync`
+ + `--ignore` now removes dependencies of ignored targets
+
+* `examples`
+ + update `sync-asroot` to use `AUR_BUILD_PKGLIST`
+
+## 12.1
+
+* `AUR.pm`
+ + call `urlencode()` when retrieving URIs with `AUR::Query` (#1053)
+
+* `aur-depends`
+ + documentation updates
+
+## 12
+
+* `aur-build`
+ + merge helper `aur-build--sync` back to `aur-build`
+ + avoid errors with PKGBUILDs that fail to source with `set -e`
+
+* `aur-repo-filter`
+ + `unbuffer` is now optional (#1052)
+
+* `aur-view`
+ + use null seperated lists as input to vifm(1)
+
+* `examples`
+ + add `sync-rebuild`
+
+* `lib`
+ + unset `CDPATH` where needed
+ + use `getopt` instead of `parseopts.sh` from libmakepkg
+
+* `man1`
+ + documentation updates
+
## 11
* `aur-build`
+ add `aur-build--sync` helper for local repository upgrades
- - `pacman -Syu --config` is replaced by `pacsync <repo>` and `pacman -S <repo>/<pkg>`
+ - `sudo pacman -Syu --config` is replaced by `sudo pacsync <repo>` and `sudo pacman -S <repo>/<pkg>`
- local repository upgrades are now unaffected by `--pacman-conf`
+ add `exist:` to `--results` output
- remove `--dry-run`