summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2021-12-01 13:26:37 +0100
committerAlad Wenter2021-12-01 13:26:37 +0100
commit30e09960c6ab58fe8501bd94b311c0f93942e6d0 (patch)
tree6e5c279a0105c047c7388490ebd23f966999b776
parent1d51dda1b626e14cea41eb48645fd11e6a985726 (diff)
downloadaur-30e09960c6ab58fe8501bd94b311c0f93942e6d0.tar.gz
aurutils: update to 3.2.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--aurutils.changelog87
-rw-r--r--aurutils.install11
-rw-r--r--aurutils.pub2
5 files changed, 107 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6395c17a05ac..5b923f579bc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,22 @@
pkgbase = aurutils
pkgdesc = helper tools for the arch user repository
- pkgver = 3.1.2
- pkgrel = 2
+ pkgver = 3.2.0
+ pkgrel = 1
url = https://github.com/AladW/aurutils
install = aurutils.install
changelog = aurutils.changelog
arch = any
license = custom:ISC
- makedepends = signify
depends = git
depends = jq
depends = pacutils
depends = curl
+ depends = expect
optdepends = bash-completion: bash completion
optdepends = zsh: zsh completion
optdepends = devtools: aur-chroot
optdepends = vifm: default pager
- source = https://github.com/AladW/aurutils/releases/download/3.1.2/aurutils-3.1.2.tar.gz
- source = https://github.com/AladW/aurutils/releases/download/3.1.2/aurutils-3.1.2.tar.gz.signify
- source = aurutils.pub
- sha256sums = 86a80ae8327aeeb4932c7709767b2be5fae19281a5bcc78b2b10197e97c32afb
- sha256sums = SKIP
- sha256sums = a2c32b0dba4da40b83ff31cce48a00faed5ed2f663c060a865d31caeb1e4ed39
+ source = aurutils-3.2.0.tar.gz::https://github.com/AladW/aurutils/archive/refs/tags/3.2.0.tar.gz
+ sha256sums = 60214a21a05b2dfe5f9e14b58a0c8beacc1a82841022956d60ac29e77f5e21da
pkgname = aurutils
-
diff --git a/PKGBUILD b/PKGBUILD
index 11e29291359c..68b6c57476db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,21 @@
# Maintainer: Alad Wenter <https://github.com/AladW>
pkgname=aurutils
-pkgver=3.1.2
-pkgrel=2
+pkgver=3.2.0
+pkgrel=1
pkgdesc='helper tools for the arch user repository'
url='https://github.com/AladW/aurutils'
arch=('any')
license=('custom:ISC')
-source=("$url/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
- "$url/releases/download/$pkgver/$pkgname-$pkgver.tar.gz.signify"
- 'aurutils.pub')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
changelog=aurutils.changelog
install=aurutils.install
-sha256sums=('86a80ae8327aeeb4932c7709767b2be5fae19281a5bcc78b2b10197e97c32afb'
- 'SKIP'
- 'a2c32b0dba4da40b83ff31cce48a00faed5ed2f663c060a865d31caeb1e4ed39')
-depends=('git' 'jq' 'pacutils' 'curl')
-makedepends=('signify')
+sha256sums=('60214a21a05b2dfe5f9e14b58a0c8beacc1a82841022956d60ac29e77f5e21da')
+depends=('git' 'jq' 'pacutils' 'curl' 'expect')
optdepends=('bash-completion: bash completion'
'zsh: zsh completion'
'devtools: aur-chroot'
'vifm: default pager')
-prepare() {
- signify -V -p aurutils.pub -m "$pkgname-$pkgver".tar.gz \
- -x "$pkgname-$pkgver".tar.gz.signify
-}
-
build() {
cd "$pkgname-$pkgver"
make
diff --git a/aurutils.changelog b/aurutils.changelog
index 6d7dd4b0343e..7c2ac60ea803 100644
--- a/aurutils.changelog
+++ b/aurutils.changelog
@@ -1,4 +1,89 @@
-## 3.0.0 - 2020-10-26
+## 3.2.0
+
+* `aur-build`
+ + retrieve database extension from `AUR_DBEXT` (defaults to .db) (#700)
+ + resolve path argument to `--results`
+ + use `aur repo --status` for repository selection
+ - allows specifying `--root` without `--database`
+ + print diagnostic if packages were not moved to local repository (#794)
+ + merge `--config` and `--pacman-conf` (#808, #824)
+ + fallback to /etc/aurutils/pacman-<arch>.conf if --chroot is used without --database (#846)
+ + add diagnostic if chroot pacman.conf is non-existing (#783)
+
+* `aur-depends`
+ + add `--no-depends`, `--no-makedepends`, `--no-checkdepends` (#826)
+ + add dependency kind column to `--table` output
+
+* `aur-chroot`
+ + preserve `SSH_AUTH_SOCK` to support ssh-based operations (#832)
+
+* `aur-repo`
+ + retrieve database extension from `AUR_DBEXT` (defaults to .db) (#700)
+ + add `--status`
+ - `repo:<NAME>\nroot:<PATH>\npath:<PATH/NAME.DBEXT>` output format
+ - replaces `--path`
+ + rename `--repo-list` to `--list-repo`
+ + rename `--path-list` to `--list-path`
+
+* `aur-repo-filter`
+ + run `pacsift` with `unbuffer` (#804)
+
+* `aur-vercmp`
+ + remove colon from `checkupdates` and `equal_or_newer` format (#833)
+
+## 3.1.2 - 2020-11-09
+
+This releases fixes a regression in 3.1.1 where `AUR_LIB_DIR` was not
+subsituted in `aur`.
+
+## 3.1.1 - 2020-11-09
+
+* `aur`
+ + add `--version`
+
+## 3.1.0 - 2020-11-09
+
+* `aur`
+ + fix example `aur-remove` script (#785)
+
+* `aur-build`
+ + change default pacman-conf for chroot builds to /etc/aurutils/pacman-<dbname>.conf
+ + clarify conditions on pacman-conf for chroot builds in `aur-build.1`
+
+* `aur-chroot`
+ + add `--create`
+ - seperate mode which runs `mkarchroot` with packages taken from the command-line
+ - defaults to base-devel (and multilib-devel, if applicable) if no packages are specified
+ - `--update` no longer runs `mkarchroot`
+ + `--packagelist` now uses `makepkg.conf` inside the container
+ + add `Devtools limitations` section to `aur-chroot.1` (#782)
+ + add additional error messages for missing pacman configuration
+
+* `aur-repo`
+ + add `--path-list`
+ + update man page for new arguments (#784)
+ + remove `--ini` (only offered pacman.conf information)
+
+## 3.0.3 - 2020-11-02
+
+* fix broken `zsh` completion (#776)
+* use `/tmp/aurutils-$UID` as default temporary directory (#775)
+
+## 3.0.2 - 2020-10-30
+
+* `aur-sync`
+ + add missing `--suffix` option (#773)
+
+## 3.0.1 - 2020-10-29
+
+The commits:
+
++ aur-sync: use XDG_RUNTIME_DIR for view directory (5341c059736d3eff59daea5cb52b7d35c98d0824)
++ aur-repo: simplify command line (57c1b2157806e645e7de85bf24e2c28b7d5f4458)
+
+were part of the 3.0.0 release tarball, but not the 3.0.0 tag. The 3.0.1 tag now includes these commits.
+
+## 3.0.0 - 2020-10-29
* `aur`
+ add `AUR_EXEC_PATH` environment variable
diff --git a/aurutils.install b/aurutils.install
index bf936df3d7d8..e6b7798e32f3 100644
--- a/aurutils.install
+++ b/aurutils.install
@@ -35,4 +35,15 @@ moved from /usr/share/devtools/pacman-aur.conf to
More information about this file was added to the aur-build man page.
EOF
fi
+
+ if (( $(vercmp '3.2.0-1' "$2") == 1 )); then
+ cat >&2 <<-EOF
+As of 3.2.0, if --chroot is specified without --database, aur-build assumes
+pacman.conf is located in /etc/pacman-$(uname -m).conf.
+
+See the 3.2.0 changelog for more information:
+
+https://github.com/AladW/aurutils/releases/tag/3.2.0
+EOF
+ fi
}
diff --git a/aurutils.pub b/aurutils.pub
deleted file mode 100644
index c0dd794692cf..000000000000
--- a/aurutils.pub
+++ /dev/null
@@ -1,2 +0,0 @@
-untrusted comment: signify public key (aurutils 3.1)
-RWSiKm8qeKjPfppkN7lm/N4qENa3Racl7DRMfWK4JQS7bl2i/NuI3ZZG