summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2022-01-17 16:03:26 +0100
committerAlad Wenter2022-01-17 16:03:26 +0100
commit3e2395a1e30a971f08bf1bc387a66b6b2cbba7c6 (patch)
treebea786694561d748f15ccabfbc99fdb4d557cb20
parent3c5f78de10e9c08905f5a634133350e5e0c202de (diff)
downloadaur-3e2395a1e30a971f08bf1bc387a66b6b2cbba7c6.tar.gz
aurutils: update changelog
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--aurutils.changelog56
3 files changed, 59 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f924b8b2257..8ff054dbeaa4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aurutils
pkgdesc = helper tools for the arch user repository
pkgver = 4.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/AladW/aurutils
install = aurutils.install
changelog = aurutils.changelog
@@ -17,6 +17,6 @@ pkgbase = aurutils
optdepends = devtools: aur-chroot
optdepends = vifm: default pager
source = aurutils-4.2.tar.gz::https://github.com/AladW/aurutils/archive/refs/tags/4.2.tar.gz
- sha256sums = 32593e29ff0dbe5dbaeba88d95424b2d399335af789899f4042d609ab4d86415
+ sha256sums = 7f809672ebcd26787b74fb2b39b5e223ccda791776ae4a581d8379db184c9a0e
pkgname = aurutils
diff --git a/PKGBUILD b/PKGBUILD
index 239ca4c2f2f9..3ccb047e2cc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alad Wenter <https://github.com/AladW>
pkgname=aurutils
pkgver=4.2
-pkgrel=1
+pkgrel=2
pkgdesc='helper tools for the arch user repository'
url='https://github.com/AladW/aurutils'
arch=('any')
diff --git a/aurutils.changelog b/aurutils.changelog
index 4f45157bacf9..53aa7ebba67b 100644
--- a/aurutils.changelog
+++ b/aurutils.changelog
@@ -1,3 +1,59 @@
+## 4.2
+
+* `aur-build`
+ + support PACMAN_AUTH environment variable for custom elevation command
+
+* `aur-repo`
+ + improve error handling
+ + remove extraneous `--` on `--path` output
+
+## 4.1
+
+* `aur-build`
+ + handle absolute paths in `--arg-file`
+
+* `aur-pkglist`
+ + add `--users` (`-U`) to retrieve a list of AUR users
+ + update aur-pkglist(1) man page
+
+* `aur-repo`
+ + fix formatting for `--table` and packages with no dependencies
+
+## 4
+
+* `aur-build`
+ + add `--no-check` (`makepkg --nocheck`)
+
+* `aur-search`
+ + add `--table`
+
+* `aur-fetch`
+ + add compatibility options (`--recurse`)
+
+* `aur-repo`
+ + add compatibility options (`--path`, `--path-list`, `--repo-list`)
+ + fix regression with `AUR_QUERY_PARALLEL`
+
+* `aur-sync`
+ + add `--no-check` (short for `--no-checkdepends`)
+ - implies `aur-build --no-check`
+ + apply `--ignore` to local repository targets
+ + `--ignore-file` now works with process substitution (#880)
+ + remove `--no-depends`, `--no-makedepends`
+
+## 3.3.0
+
+`aur-query` and `aur-fetch` now take arguments from the command-line
+by default. If `-` or `/dev/stdin` is the first (and only) arguments,
+they are taken from `stdin` instead. In particular, `aur fetch --recurse`
+is now written as `aur depends --pkgbase ... | aur fetch -`, and the
+explicit `--recurse` option was removed.
+
+The `-` argument propagates to `aur-depends` and `aur-search`
+transparently. Additionally, `aur-sync` no longer calls `aur-depends`
+and `aur-fetch` with `xargs`, avoiding the 123 exit code on failure of
+these commands.
+
## 3.2.1
* `aur-query`