summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2016-05-02 09:45:44 +0200
committerAlad Wenter2016-05-02 09:45:44 +0200
commit5baf494029ca9240d7de18830922ca5bdff7c3f8 (patch)
tree1ce2d891d22298d42806cdb5efa14cb0a937cb4a
parent30cb25f0d251352c35858cb134add92d06402750 (diff)
downloadaur-5baf494029ca9240d7de18830922ca5bdff7c3f8.tar.gz
bump 0.8.4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dca7da9a074c..08cff350c185 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Apr 25 13:09:57 UTC 2016
+# Mon May 2 07:45:44 UTC 2016
pkgbase = aurutils
pkgdesc = helper tools for the arch user repository
- pkgver = 0.8.3
+ pkgver = 0.8.4
pkgrel = 1
url = https://github.com/AladW/aurutils
arch = any
@@ -11,16 +11,13 @@ pkgbase = aurutils
makedepends = git
depends = pacman>=5.0
depends = git
- depends = repose
depends = jshon
- depends = pacutils
depends = expac
- depends = aria2
- depends = datamash
- optdepends = devtools: aurbuild -c
+ depends = aria2>=1.23.0
+ optdepends = devtools: build in an nspawn container
optdepends = vifm: improved build file interaction
- source = https://github.com/AladW/aurutils/archive/0.8.3.tar.gz
- md5sums = fd112110e905afde4c8105fe72f27348
+ source = https://github.com/AladW/aurutils/archive/0.8.4.tar.gz
+ md5sums = e1d0033cc330e1901710c7970823a9f2
pkgname = aurutils
diff --git a/PKGBUILD b/PKGBUILD
index e6b45861a0e1..c2c75f02c74b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,25 @@
pkgname=aurutils
-pkgver=0.8.3
+pkgver=0.8.4
pkgrel=1
pkgdesc='helper tools for the arch user repository'
arch=('any')
url=https://github.com/AladW/aurutils
license=('ISC')
-source=("https://github.com/AladW/aurutils/archive/$pkgver.tar.gz")
-md5sums=('fd112110e905afde4c8105fe72f27348')
-depends=('pacman>=5.0' 'git' 'repose' 'jshon' 'pacutils' 'expac' 'aria2' 'datamash')
+source=("$url/archive/$pkgver.tar.gz")
+md5sums=('e1d0033cc330e1901710c7970823a9f2')
+depends=('pacman>=5.0' 'git' 'jshon' 'expac' 'aria2>=1.23.0')
+ 'repose' 'pacutils' 'datamash'
checkdepends=('shellcheck')
makedepends=('git')
-optdepends=('devtools: aurbuild -c'
+optdepends=('devtools: build in an nspawn container'
'vifm: improved build file interaction')
check() {
cd "$pkgname-$pkgver"
- LANG=C shellcheck -e 2016 -x bin/*
+ make check
}
package() {
cd "$pkgname-$pkgver"
- install -d "$pkgdir"/usr/{bin,share{/man/man1,{/licenses,/doc}/aurutils}}
-
- install -m755 bin/* "$pkgdir"/usr/bin/
- install -m644 LICENSE "$pkgdir"/usr/share/licenses/aurutils/
- install -m644 CREDITS README "$pkgdir"/usr/share/doc/aurutils/
- install -m644 doc/* "$pkgdir"/usr/share/man/man1/
+ make DESTDIR="$pkgdir/" install
}
-