summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaden Peterson2019-03-30 17:17:11 -0700
committerJaden Peterson2019-03-30 17:17:11 -0700
commit0e852243cd7a2d219a2450fde8eeb55189e532e8 (patch)
tree27ff8cc2f99a085c17e4dfa5150a6cb7a21e0647
downloadaur-0e852243cd7a2d219a2450fde8eeb55189e532e8.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d723dcdfb00b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = aurvote-utils
+ pkgdesc = A set of utilities for managing AUR votes
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/jadenPete/aurvote-utils
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-beautifulsoup4
+ depends = python-requests
+ conflicts = aurvote
+ source = https://github.com/jadenPete/aurvote-utils/archive/v1.0.0.tar.gz
+ sha256sums = d8b992f836a663584c4b447befc46e47824795143780b4c23d2da8481dc12711
+
+pkgname = aurvote-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..321d1935898e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Jaden Peterson <jadenpeterson150@gmail.com>
+
+pkgname=aurvote-utils
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A set of utilities for managing AUR votes'
+arch=('any')
+url=https://github.com/jadenPete/aurvote-utils
+conflicts=('aurvote')
+license=('MIT')
+depends=('python' 'python-beautifulsoup4' 'python-requests')
+source=("https://github.com/jadenPete/aurvote-utils/archive/v${pkgver}.tar.gz")
+sha256sums=('d8b992f836a663584c4b447befc46e47824795143780b4c23d2da8481dc12711')
+
+package() {
+ cd "aurvote-utils-${pkgver}"
+ install -D aurvote "${pkgdir}/usr/bin/aurvote"
+ install aurvote-auto "${pkgdir}/usr/bin/aurvote-auto"
+}