summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaden Peterson2019-03-30 17:06:32 -0700
committerJaden Peterson2019-03-30 17:06:32 -0700
commit32e578e5290026dc2d0bd0d6b092d756ebe4ef33 (patch)
treed42f570775eea29ab9b01b17d785d5925f75b81d
downloadaur-32e578e5290026dc2d0bd0d6b092d756ebe4ef33.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e148ef85c4f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = aurvote-utils-git
+ pkgdesc = A set of utilities for managing AUR votes
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/jadenPete/aurvote-utils
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-beautifulsoup4
+ depends = python-requests
+ provides = aurvote-utils
+ conflicts = aurvote-utils
+ conflicts = aurvote
+ source = git+https://github.com/jadenPete/aurvote-utils.git
+ sha256sums = SKIP
+
+pkgname = aurvote-utils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bde505c89244
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jaden Peterson <jadenpeterson150@gmail.com>
+
+pkgname=aurvote-utils-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A set of utilities for managing AUR votes'
+arch=('any')
+url=https://github.com/jadenPete/aurvote-utils
+provides=('aurvote-utils')
+conflicts=('aurvote-utils' 'aurvote')
+license=('MIT')
+depends=('python' 'python-beautifulsoup4' 'python-requests')
+makedepends=('git')
+source=("git+https://github.com/jadenPete/aurvote-utils.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd aurvote-utils
+ git describe --tags | tail -c +2 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd aurvote-utils
+ install -D aurvote "${pkgdir}/usr/bin/aurvote"
+ install aurvote-auto "${pkgdir}/usr/bin/aurvote-auto"
+}