summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhhhhhhhhhn2023-08-06 00:21:57 -0400
committerhhhhhhhhhn2023-08-06 00:21:57 -0400
commit9511374de8f9763bce25ec30a1c261257d91783f (patch)
tree855445235ad83f1e58ee6e5347dbadc582950766
downloadaur-9511374de8f9763bce25ec30a1c261257d91783f.tar.gz
Initial package commit v0.2.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3150c87044a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = austral-git
+ pkgdesc = Systems language with linear types and capability-based security.
+ pkgver = v0.2.0.r3.gd8ccef5
+ pkgrel = 1
+ url = https://github.com/austral/austral
+ arch = x86_64
+ license = Apache
+ makedepends = opam
+ makedepends = ocaml
+ makedepends = make
+ makedepends = dune
+ makedepends = git
+ depends = gmp
+ depends = glibc
+ provides = austral
+ conflicts = austral
+ source = git+https://github.com/austral/austral.git
+ sha256sums = SKIP
+
+pkgname = austral-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e64da735e370
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: hhhhhhhhhn <hhhhhhhhhn@protonmail.com>
+pkgname="austral-git"
+pkgver=v0.2.0.r3.gd8ccef5
+pkgrel=1
+pkgdesc="Systems language with linear types and capability-based security."
+arch=("x86_64")
+url="https://github.com/austral/austral"
+license=("Apache")
+conflicts=("austral")
+provides=("austral")
+depends=("gmp" "glibc")
+makedepends=("opam" "ocaml" "make" "dune" "git")
+source=("git+${url}.git")
+sha256sums=(SKIP)
+
+build() {
+ opam switch remove austral -y || true
+ cd "austral"
+ opam switch create austral 4.13.0
+ eval $(opam env --switch=austral)
+ opam install --deps-only -y .
+ make
+ opam switch remove austral -y
+}
+
+package() {
+ cd "austral"
+ install -Dm 755 ./austral "$pkgdir/usr/local/bin/austral"
+}
+
+pkgver() {
+ cd "austral"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}