summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing2020-01-15 17:35:01 +0100
committerAndré Klitzing2020-01-16 09:48:04 +0100
commitb06f1356097c7d3076baac48e0c705f8ea934c98 (patch)
tree880baf257864a43fe4f0e6a9acf2a5bf5c7522bb
parent9f42f7f3ee7b87e227e14411cf9cb9e54a2e38ea (diff)
downloadaur-b06f1356097c7d3076baac48e0c705f8ea934c98.tar.gz
ausweisapp2 1.20.0-1: Update to new version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
-rw-r--r--qml-path.patch12
3 files changed, 17 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ac9e38c707e..dd7eb9b83e0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ausweisapp2
pkgdesc = A software application that you install on your computer to use your national identity card or your electronic residence permit for online identification
- pkgver = 1.18.2
+ pkgver = 1.20.0
pkgrel = 1
- url = https://www.ausweisapp.bund.de/ausweisapp2-home/
+ url = https://www.ausweisapp.bund.de/
arch = i686
arch = x86_64
license = custom:EUPL1.2
@@ -14,14 +14,15 @@ pkgbase = ausweisapp2
depends = qt5-svg
depends = qt5-websockets
depends = pcsclite
+ depends = http-parser
optdepends = ccid
- source = https://github.com/Governikus/AusweisApp2/releases/download/1.18.2/AusweisApp2-1.18.2.tar.gz
- source = https://github.com/Governikus/AusweisApp2/releases/download/1.18.2/AusweisApp2-1.18.2.tar.gz.asc
- source = qml-path.patch
+ optdepends = acsccid
+ optdepends = pcsc-cyberjack
+ source = https://github.com/Governikus/AusweisApp2/releases/download/1.20.0/AusweisApp2-1.20.0.tar.gz
+ source = https://github.com/Governikus/AusweisApp2/releases/download/1.20.0/AusweisApp2-1.20.0.tar.gz.asc
validpgpkeys = 699BF3055B0A49224EFDE7C72D7479A531451088
- sha256sums = 2b21d25ca065d1004e3d72f418d542240ab6b62e9e68ed05958e70455f4a3e64
+ sha256sums = 8289678d19e2c4d5845afd7a516d645f78d8e0a09f857a8d5cc1037569d2e807
sha256sums = SKIP
- sha256sums = 52a45aa940b0d6fe5236e45cb3c587237955b7e128eb5f6b5c6398e034778ca4
pkgname = ausweisapp2
diff --git a/PKGBUILD b/PKGBUILD
index 49a6bc74556f..aaa18e38470d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,31 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ausweisapp2
-pkgver=1.18.2
+pkgver=1.20.0
pkgrel=1
pkgdesc="A software application that you install on your computer to use your national identity card or your electronic residence permit for online identification"
arch=('i686' 'x86_64')
license=('custom:EUPL1.2')
-url="https://www.ausweisapp.bund.de/ausweisapp2-home/"
-depends=('qt5-declarative' 'qt5-graphicaleffects' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-websockets' 'pcsclite')
+url="https://www.ausweisapp.bund.de/"
+depends=('qt5-declarative' 'qt5-graphicaleffects' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-websockets' 'pcsclite' 'http-parser')
makedepends=('cmake' 'qt5-tools')
-optdepends=('ccid')
-source=("https://github.com/Governikus/AusweisApp2/releases/download/${pkgver}/AusweisApp2-${pkgver}.tar.gz"{,.asc}
- "qml-path.patch")
+optdepends=('ccid' 'acsccid' 'pcsc-cyberjack')
+source=("https://github.com/Governikus/AusweisApp2/releases/download/${pkgver}/AusweisApp2-${pkgver}.tar.gz"{,.asc})
validpgpkeys=('699BF3055B0A49224EFDE7C72D7479A531451088')
-sha256sums=('2b21d25ca065d1004e3d72f418d542240ab6b62e9e68ed05958e70455f4a3e64'
- 'SKIP'
- '52a45aa940b0d6fe5236e45cb3c587237955b7e128eb5f6b5c6398e034778ca4')
-
-prepare() {
- cd "${srcdir}/AusweisApp2-${pkgver}"
-
- # TODO: Ask upstream whether copying all that QML stuff is really necessary
- patch -Np1 < "${srcdir}/qml-path.patch"
-}
+sha256sums=('8289678d19e2c4d5845afd7a516d645f78d8e0a09f857a8d5cc1037569d2e807'
+ 'SKIP')
build() {
mkdir -p "${srcdir}/Build"
cd "${srcdir}/Build"
- cmake -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/opt/AusweisApp2 "${srcdir}/AusweisApp2-${pkgver}"
+ cmake -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr "${srcdir}/AusweisApp2-${pkgver}"
make
}
package() {
cd "${srcdir}/Build"
- make install DESTDIR="${pkgdir}"
- install -dm755 "${pkgdir}/usr/bin"
- # fwr the translation directory is expected to be located right next to the application binary
- ln -s "/opt/AusweisApp2/translations" "${pkgdir}/opt/AusweisApp2/bin/"
- ln -s "/opt/AusweisApp2/bin/AusweisApp2" "${pkgdir}/usr/bin/"
- mv "${pkgdir}/opt/AusweisApp2/share" "${pkgdir}/usr/share"
+ make DESTDIR="${pkgdir}" install
install -Dm644 "${srcdir}/AusweisApp2-${pkgver}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
}
diff --git a/qml-path.patch b/qml-path.patch
deleted file mode 100644
index 2f5ee2cdc827..000000000000
--- a/qml-path.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur package.pristine/cmake/Install.cmake package.new/cmake/Install.cmake
---- package.pristine/cmake/Install.cmake 2019-09-30 14:14:05.000000000 +0200
-+++ package.new/cmake/Install.cmake 2019-11-03 14:20:21.106015892 +0100
-@@ -330,7 +330,7 @@
- # qt qml plugins
- IF(DESKTOP AND TARGET Qt5::Qml)
- FOREACH(entry QtQuick QtQuick.2 QtQml QtGraphicalEffects Qt)
-- INSTALL(DIRECTORY ${QT_HOST_PREFIX}/qml/${entry} DESTINATION ${DEFAULT_FILE_DESTINATION}/qml COMPONENT Runtime PATTERN "*.dylib" EXCLUDE)
-+ INSTALL(DIRECTORY ${QT_HOST_PREFIX}/lib/qt/qml/${entry} DESTINATION ${DEFAULT_FILE_DESTINATION}/qml COMPONENT Runtime PATTERN "*.dylib" EXCLUDE)
- ENDFOREACH()
- ENDIF()
-