summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing2020-09-15 14:46:14 +0200
committerAndré Klitzing2020-09-15 14:46:14 +0200
commitf4d7a4e9e68d0dd6d54123739a69513b25848c2d (patch)
tree0c328081b748a8082bb1575fda2e05bc4e7038ec
parentf8f7a2e48cb3d8878e496866000701d86e16adf7 (diff)
downloadaur-f4d7a4e9e68d0dd6d54123739a69513b25848c2d.tar.gz
Upgrade to 1.20.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3736bf00160..886d8006847d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ausweisapp2
pkgdesc = A software application that you install on your computer to use your national identity card or your electronic residence permit for online identification
- pkgver = 1.20.1
+ pkgver = 1.20.2
pkgrel = 1
url = https://www.ausweisapp.bund.de/
arch = i686
@@ -18,10 +18,10 @@ pkgbase = ausweisapp2
optdepends = ccid
optdepends = acsccid
optdepends = pcsc-cyberjack
- source = https://github.com/Governikus/AusweisApp2/releases/download/1.20.1/AusweisApp2-1.20.1.tar.gz
- source = https://github.com/Governikus/AusweisApp2/releases/download/1.20.1/AusweisApp2-1.20.1.tar.gz.asc
+ source = https://github.com/Governikus/AusweisApp2/releases/download/1.20.2/AusweisApp2-1.20.2.tar.gz
+ source = https://github.com/Governikus/AusweisApp2/releases/download/1.20.2/AusweisApp2-1.20.2.tar.gz.asc
validpgpkeys = 699BF3055B0A49224EFDE7C72D7479A531451088
- sha256sums = 3351c2390f3e22871eb645f858032c7d127ee75628093726b35ce946fc3e480a
+ sha256sums = d56505b67884b1d443fe3560004d0a644c20034b4196d1a08a4c29138fe7092b
sha256sums = SKIP
pkgname = ausweisapp2
diff --git a/PKGBUILD b/PKGBUILD
index 57568f4e20f0..69e56c5c6722 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ausweisapp2
-pkgver=1.20.1
+pkgver=1.20.2
pkgrel=1
pkgdesc="A software application that you install on your computer to use your national identity card or your electronic residence permit for online identification"
arch=('i686' 'x86_64')
@@ -12,20 +12,17 @@ makedepends=('cmake' 'qt5-tools')
optdepends=('ccid' 'acsccid' 'pcsc-cyberjack')
source=("https://github.com/Governikus/AusweisApp2/releases/download/${pkgver}/AusweisApp2-${pkgver}.tar.gz"{,.asc})
validpgpkeys=('699BF3055B0A49224EFDE7C72D7479A531451088')
-sha256sums=('3351c2390f3e22871eb645f858032c7d127ee75628093726b35ce946fc3e480a'
+sha256sums=('d56505b67884b1d443fe3560004d0a644c20034b4196d1a08a4c29138fe7092b'
'SKIP')
build() {
- mkdir -p "${srcdir}/Build"
-
- cd "${srcdir}/Build"
- cmake -DCMAKE_BUILD_TYPE=MinSizeRel -DCMAKE_INSTALL_PREFIX=/usr "${srcdir}/AusweisApp2-${pkgver}"
- make
+ cd "${srcdir}"
+ cmake -B build -DCMAKE_BUILD_TYPE=MinSizeRel -DCMAKE_INSTALL_PREFIX=/usr "${srcdir}/AusweisApp2-${pkgver}"
+ make -C build
}
package() {
- cd "${srcdir}/Build"
-
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}"
+ make -C build DESTDIR="${pkgdir}" install
install -Dm644 "${srcdir}/AusweisApp2-${pkgver}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
}