summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 14:44:08 +0200
committerAlexander F Rødseth2015-06-10 14:44:08 +0200
commit9397fa43281d01308ca6449a9071b8c79077aa51 (patch)
treee3715f9feff4ac21e17c0af49c0873dd7f66d435
downloadaur-9397fa43281d01308ca6449a9071b8c79077aa51.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
-rw-r--r--aut2exe.sh13
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1c2b6408866
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = aut2exe
+ pkgdesc = AutoIt compiler (from au3 to exe)
+ pkgver = 3.3.6.1
+ pkgrel = 3
+ url = http://www.autoitscript.com/
+ arch = any
+ license = custom
+ makedepends = p7zip
+ depends = wine
+ optdepends = aut2exe-docs: help files and sample code
+ source = http://www.autoitscript.com/cgi-bin/getfile.pl?autoit3/autoit-v3-sfx.exe
+ source = http://www.autoitscript.com/autoit3/docs/license.htm
+ source = aut2exe.sh
+ md5sums = a285f2a980d258fc1f095d12ada885e3
+ md5sums = 1bc07254a7e54c7e91d8340b87860270
+ md5sums = 4b9636dd42c12a66b586da8daf25c20c
+
+pkgname = aut2exe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..063b4f4b6118
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+pkgname=aut2exe
+pkgver=3.3.6.1
+pkgrel=3
+pkgdesc="AutoIt compiler (from au3 to exe)"
+arch=('any')
+url="http://www.autoitscript.com/"
+license=('custom')
+depends=('wine')
+makedepends=('p7zip')
+optdepends=('aut2exe-docs: help files and sample code')
+md5sums=('a285f2a980d258fc1f095d12ada885e3'
+ '1bc07254a7e54c7e91d8340b87860270'
+ '4b9636dd42c12a66b586da8daf25c20c')
+source=("http://www.autoitscript.com/cgi-bin/getfile.pl?autoit3/autoit-v3-sfx.exe"
+ "http://www.autoitscript.com/autoit3/docs/license.htm"
+ "aut2exe.sh")
+
+build() {
+ cd "$srcdir"
+
+ msg2 "Extracting..."
+ 7z x autoit-v3-sfx.exe > /dev/null
+ mv install "$pkgname"
+}
+
+package() {
+ cd "$srcdir/$pkgname/Aut2Exe"
+
+ msg2 "Packaging executables..."
+ install -Dm644 Aut2exe.exe "$pkgdir/usr/bin/Aut2exe.exe"
+ install -Dm644 AutoItSC.bin "$pkgdir/usr/bin/AutoItSC.bin"
+ install -Dm644 upx.exe "$pkgdir/usr/bin/upx.exe"
+ install -Dm755 "$srcdir/aut2exe.sh" "$pkgdir/usr/bin/aut2exe"
+
+ msg2 "Packaging license..."
+ install -Dm644 "$srcdir/license.htm" \
+ "$pkgdir/usr/share/licenses/$pkgname/license.html"
+}
+# vim:set ts=2 sw=2 et:
diff --git a/aut2exe.sh b/aut2exe.sh
new file mode 100644
index 000000000000..52d362801dd3
--- /dev/null
+++ b/aut2exe.sh
@@ -0,0 +1,13 @@
+#!/bin/sh
+if test -z "$1"
+then
+ echo "aut2exe infile.au3 [/out outfile.exe] [/icon file.ico] [/comp 0-4] [/pack] [/nopack] [/ansi] [/unicode] [/console] [/gui]"
+else
+ if test -z "$2"
+ then
+ wine /usr/bin/Aut2exe.exe /in $* /nopack
+ else
+ wine /usr/bin/Aut2exe.exe /in $*
+ fi
+fi
+