diff options
author | Amir Zarrinkafsh | 2023-01-22 19:30:35 +1100 |
---|---|---|
committer | Amir Zarrinkafsh | 2023-01-22 19:30:35 +1100 |
commit | 246d77cacb4666f4d66077d2c340cfa46f54f7a6 (patch) | |
tree | f028f55e36df12d8b40355ef884a785200d25c93 | |
parent | ad4e6ca537c067878914f73e41188b182a25a46c (diff) | |
download | aur-246d77cacb4666f4d66077d2c340cfa46f54f7a6.tar.gz |
Utilise pnpm instead of yarn
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 8 |
2 files changed, 6 insertions, 6 deletions
@@ -1,7 +1,7 @@ pkgbase = authelia pkgdesc = The Cloud ready multi-factor authentication portal for your Apps. pkgver = 4.37.5 - pkgrel = 1 + pkgrel = 2 url = https://github.com/authelia/authelia arch = x86_64 arch = aarch64 @@ -12,7 +12,7 @@ pkgbase = authelia makedepends = go makedepends = jq makedepends = nodejs - makedepends = yarn + makedepends = pnpm conflicts = authelia-bin conflicts = authelia-git backup = etc/authelia/configuration.yml @@ -1,7 +1,7 @@ # Maintainer: Amir Zarrinkafsh <nightah at me dot com> pkgname=authelia pkgver=4.37.5 -pkgrel=1 +pkgrel=2 pkgdesc="The Cloud ready multi-factor authentication portal for your Apps." arch=('x86_64' 'aarch64' 'armv7h') url="https://github.com/authelia/authelia" @@ -12,7 +12,7 @@ makedepends=( 'go' 'jq' 'nodejs' - 'yarn' + 'pnpm' ) conflicts=( 'authelia-bin' @@ -34,8 +34,8 @@ build() { DATE=$(date +"%a, %d %b %Y %R:%S %z") XOPTIONS="-X 'github.com/authelia/authelia/v4/internal/utils.BuildBranch=v${pkgver}' -X 'github.com/authelia/authelia/v4/internal/utils.BuildTag=${TAG}' -X 'github.com/authelia/authelia/v4/internal/utils.BuildCommit=${COMMIT}' -X 'github.com/authelia/authelia/v4/internal/utils.BuildDate=${DATE}' -X 'github.com/authelia/authelia/v4/internal/utils.BuildState=${STATE}' -X 'github.com/authelia/authelia/v4/internal/utils.BuildNumber=AUR'" - yarn install --frozen-lockfile --ignore-scripts - yarn build + pnpm install --frozen-lockfile --ignore-scripts + pnpm build cd .. cp -R api internal/server/public_html/ go build -ldflags "-w ${XOPTIONS}" -trimpath -o authelia cmd/authelia/*.go |